aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-01-28 12:29:03 +0200
committerKhem Raj <raj.khem@gmail.com>2021-02-01 10:44:27 -0800
commit0532eaf50b33446ebb2feb7d4d56184a9681b990 (patch)
tree2c39ac0592c605abada870c667c10305cc5ffdd9 /meta-python
parent82b80e6ab10a0cf678428ff11832dc9b90f9d5a6 (diff)
downloadmeta-openembedded-contrib-0532eaf50b33446ebb2feb7d4d56184a9681b990.tar.gz
python3-xlrd: Upgrade 1.2.0 -> 2.0.1
Upgrade to release 2.0.1: - Use the README as the long description on PyPI. - Remove support for anything other than .xls files. - Remove support for psyco. - Change the default encoding used when no CODEPAGE record can be found from ascii to iso-8859-1. - Add support for iterating over :class:`~xlrd.book.Book` objects. - Add support for item access from :class:`~xlrd.book.Book` objects, where integer indices and string sheet names are supported. - Non-unicode spaces are now stripped from the "last author" information. - Workbook corruption errors can now be ignored using the ignore_workbook_corruption option to :class:`~xlrd.open_workbook`. - Handle WRITEACCESS records with invalid trailing characters. - Officially support Python 3.8 and 3.9. Get the source code from the git repository rather than from PyPI to obtain the tests. License-Update: Use file LICENSE. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-xlrd_2.0.1.bb (renamed from meta-python/recipes-devtools/python/python3-xlrd_1.2.0.bb)17
1 files changed, 9 insertions, 8 deletions
diff --git a/meta-python/recipes-devtools/python/python3-xlrd_1.2.0.bb b/meta-python/recipes-devtools/python/python3-xlrd_2.0.1.bb
index 571dba6fa8..8587ea8f33 100644
--- a/meta-python/recipes-devtools/python/python3-xlrd_1.2.0.bb
+++ b/meta-python/recipes-devtools/python/python3-xlrd_2.0.1.bb
@@ -4,16 +4,19 @@ DESCRIPTION = "Extract data from Excel spreadsheets (.xls and .xlsx,\
Strong support for Excel dates. Unicode-aware."
HOMEPAGE = "http://www.python-excel.org/"
LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://PKG-INFO;md5=5f4244d51fcc1e7cc2d43e96891b2f80"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=00ea1e843a43c20d9b63a8112239b0d1"
-SRC_URI[md5sum] = "e5d5b96924d791b22898b622eb3e918e"
-SRC_URI[sha256sum] = "546eb36cee8db40c3eaa46c351e67ffee6eeb5fa2650b71bc4c758a29a1b29b2"
+SRC_URI[sha256sum] = "f72f148f54442c6b056bf931dbc34f986fd0c3b0b6b5a58d013c9aef274d0c88"
-SRC_URI += " \
- file://run-ptest \
+
+SRC_URI = "git://github.com/python-excel/xlrd.git \
+ file://run-ptest \
"
+SRCREV = "b8d573e11ec149da695d695c81a156232b89a949"
+
+S = "${WORKDIR}/git"
-inherit ptest pypi setuptools3
+inherit ptest setuptools3
RDEPENDS_${PN} += "${PYTHON_PN}-compression ${PYTHON_PN}-io ${PYTHON_PN}-pprint ${PYTHON_PN}-shell"
@@ -24,8 +27,6 @@ RDEPENDS_${PN}-ptest += " \
do_install_ptest() {
install -d ${D}${PTEST_PATH}/tests
cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
- install -d ${D}${PTEST_PATH}/examples
- cp -rf ${S}/examples/* ${D}${PTEST_PATH}/examples/
}
BBCLASSEXTEND = "native nativesdk"