aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-04-16 10:50:32 -0700
committerKhem Raj <raj.khem@gmail.com>2021-04-21 08:26:07 -0700
commitf528f9614f9f2b4712bbbd37041c29b505322f4d (patch)
tree1c3f39ec44279038d8eaf2f6e0dd41d602c1b888 /meta-python
parent660e62b64531df16c616668747a68b9a62774fbf (diff)
downloadmeta-openembedded-contrib-f528f9614f9f2b4712bbbd37041c29b505322f4d.tar.gz
python3-icu: Upgrade to 2.7.2
License-Update: Use info in setup.py for license as dedicated LICENSE file has disappeared. License still is MIT Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-icu/0001-Fix-host-contamination-of-include-files.patch (renamed from meta-python/recipes-devtools/python/python3-icu/fix_host_include.patch)26
-rw-r--r--meta-python/recipes-devtools/python/python3-icu_2.6.bb13
-rw-r--r--meta-python/recipes-devtools/python/python3-icu_2.7.2.bb13
3 files changed, 31 insertions, 21 deletions
diff --git a/meta-python/recipes-devtools/python/python3-icu/fix_host_include.patch b/meta-python/recipes-devtools/python/python3-icu/0001-Fix-host-contamination-of-include-files.patch
index 1b6e890436..c45217a88a 100644
--- a/meta-python/recipes-devtools/python/python3-icu/fix_host_include.patch
+++ b/meta-python/recipes-devtools/python/python3-icu/0001-Fix-host-contamination-of-include-files.patch
@@ -1,17 +1,24 @@
-Fixed host contamination of include files
+From 8abf79f77d9151d6786da3c8e868117822bce6d4 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Fri, 16 Apr 2021 10:48:36 -0700
+Subject: [PATCH] Fix host contamination of include files
python3-icu-2.5-r0 do_package_qa: QA Issue: python3-icu: The compile log indicates that host include and/or library paths were used.
Also, don't use icu-config
-Upstream-Status: [inappropriate] OE specific
+Upstream-Status: Inappropriate [OE specific]
Signed-off-by: Armin Kuster <akuster808@gmail.com>
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ setup.py | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
-Index: PyICU-2.5/setup.py
-===================================================================
---- PyICU-2.5.orig/setup.py
-+++ PyICU-2.5/setup.py
-@@ -81,7 +81,7 @@ Building PyICU %s for ICU %s (max ICU ma
+diff --git a/setup.py b/setup.py
+index e647db4..abed399 100644
+--- a/setup.py
++++ b/setup.py
+@@ -81,7 +81,7 @@ Building PyICU %s for ICU %s (max ICU major version supported: %s)
CONFIGURE_WITH_ICU_CONFIG = {
'darwin': True,
@@ -20,7 +27,7 @@ Index: PyICU-2.5/setup.py
'freebsd': False, # not tested
'win32': False, # no icu-config
'sunos5': False, # not tested
-@@ -274,7 +274,6 @@ setup(name="PyICU",
+@@ -267,7 +267,6 @@ setup(name="PyICU",
ext_modules=[Extension('_icu',
[filename for filename in sorted(os.listdir(os.curdir))
if filename.endswith('.cpp')],
@@ -28,3 +35,6 @@ Index: PyICU-2.5/setup.py
extra_compile_args=_cflags,
extra_link_args=_lflags,
libraries=_libraries)],
+--
+2.31.1
+
diff --git a/meta-python/recipes-devtools/python/python3-icu_2.6.bb b/meta-python/recipes-devtools/python/python3-icu_2.6.bb
deleted file mode 100644
index 58f5e563bf..0000000000
--- a/meta-python/recipes-devtools/python/python3-icu_2.6.bb
+++ /dev/null
@@ -1,13 +0,0 @@
-SUMMARY = "Python extension wrapping the ICU C++ API"
-SECTION = "devel/python"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=c7c4bfd81a21e3b6368bdcced992bf59"
-
-DEPENDS += "pkgconfig icu"
-
-PYPI_PACKAGE = "PyICU"
-SRC_URI[sha256sum] = "a9a5bf6833360f8f69e9375b91c1a7dd6e0c9157a42aee5bb7d6891804d96371"
-
-SRC_URI += "file://fix_host_include.patch"
-
-inherit pypi setuptools3
diff --git a/meta-python/recipes-devtools/python/python3-icu_2.7.2.bb b/meta-python/recipes-devtools/python/python3-icu_2.7.2.bb
new file mode 100644
index 0000000000..4c064c3d4c
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-icu_2.7.2.bb
@@ -0,0 +1,13 @@
+SUMMARY = "Python extension wrapping the ICU C++ API"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://setup.py;beginline=244;endline=252;md5=3e00c41c6d04310707992b93307a224f"
+
+DEPENDS += "pkgconfig icu"
+
+PYPI_PACKAGE = "PyICU"
+SRC_URI[sha256sum] = "1382869b22d91cc99274f9b525fa7d9199b44d9007ff0036a09747839a01e9dc"
+
+SRC_URI += "file://0001-Fix-host-contamination-of-include-files.patch"
+
+inherit pypi setuptools3