aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2023-11-07 13:08:47 +0200
committerKhem Raj <raj.khem@gmail.com>2023-11-07 23:11:24 -0800
commit0fd1c5280ed31cb8e800df2f8076c11a494cf664 (patch)
tree8aa568590417a77df34a700b4616874752c35fb3 /meta-python
parent3ca88006d9c16e562acf38d2f736486aec93efc5 (diff)
downloadmeta-openembedded-contrib-0fd1c5280ed31cb8e800df2f8076c11a494cf664.tar.gz
python3-pdm: add recipe
Add pdm, a modern Python package and dependency manager supporting the latest PEP standards. Version 2.10.1 brings: - Fix list index out of range when build error message is empty - Fix find_link sources being exported as --extra--index-url - Fix an installation failure when install.cache = true - Fix a resolution issue that extra dependencies are not resolved when the bare dependency has more specific version constraint Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-pdm_2.10.1.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pdm_2.10.1.bb b/meta-python/recipes-devtools/python/python3-pdm_2.10.1.bb
new file mode 100644
index 0000000000..d5aab3db74
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pdm_2.10.1.bb
@@ -0,0 +1,15 @@
+SUMMARY = "A modern Python package and dependency manager supporting the latest PEP standards"
+HOMEPAGE = "https://pdm-project.org/latest/"
+LICENSE = "MIT"
+SECTION = "devel/python"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2eb31a2cc1a758c34b499f287dd04ef2"
+
+SRC_URI[sha256sum] = "d166531c659fc4905933546544dd2e16cf648c2ba6d898c82126ad6a42117a81"
+
+inherit pypi python_setuptools_build_meta
+
+DEPENDS += " \
+ ${PYTHON_PN}-pdm-backend-native \
+"
+
+BBCLASSEXTEND = "native nativesdk"