aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorAndrey Zhizhikin <andrey.z@gmail.com>2020-01-20 20:17:50 +0000
committerKhem Raj <raj.khem@gmail.com>2020-01-22 09:56:34 -0800
commite6ced573087a6416ec50dce4cf281758be9a2d4c (patch)
treeea0b161d5de77d03572e76e6e6b9e3482cad8d61 /meta-python
parent1ae31787167240729a78a442a378ef354583c012 (diff)
downloadmeta-openembedded-contrib-e6ced573087a6416ec50dce4cf281758be9a2d4c.tar.gz
meta-python: update recipes to use python3 classes
Update recipes to use python3 classes instead of deprecated python2 variants. Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-connectivity/gateone/gateone_git.bb2
-rw-r--r--meta-python/recipes-connectivity/telepathy/telepathy-python_0.15.19.bb2
-rw-r--r--meta-python/recipes-devtools/python-jsonref/python-jsonref.inc2
-rw-r--r--meta-python/recipes-devtools/python/pamela_0.3.0.bb2
-rw-r--r--meta-python/recipes-devtools/python/pyrtm_0.4.2.bb2
-rw-r--r--meta-python/recipes-devtools/python/python-yappi.inc2
-rw-r--r--meta-python/recipes-devtools/python/python3-robotframework-seriallibrary_0.3.1.bb2
7 files changed, 7 insertions, 7 deletions
diff --git a/meta-python/recipes-connectivity/gateone/gateone_git.bb b/meta-python/recipes-connectivity/gateone/gateone_git.bb
index 5d2ca00ef5..37d3564521 100644
--- a/meta-python/recipes-connectivity/gateone/gateone_git.bb
+++ b/meta-python/recipes-connectivity/gateone/gateone_git.bb
@@ -14,7 +14,7 @@ SRC_URI = "git://github.com/liftoff/GateOne.git;branch=master \
S = "${WORKDIR}/git"
-inherit setuptools python-dir systemd update-rc.d
+inherit setuptools3 python3-dir systemd update-rc.d
DISTUTILS_INSTALL_ARGS += " \
--install-data=${PYTHON_SITEPACKAGES_DIR} \
diff --git a/meta-python/recipes-connectivity/telepathy/telepathy-python_0.15.19.bb b/meta-python/recipes-connectivity/telepathy/telepathy-python_0.15.19.bb
index b7aea24a79..2e8da0805d 100644
--- a/meta-python/recipes-connectivity/telepathy/telepathy-python_0.15.19.bb
+++ b/meta-python/recipes-connectivity/telepathy/telepathy-python_0.15.19.bb
@@ -14,7 +14,7 @@ SRC_URI = "http://telepathy.freedesktop.org/releases/${BPN}/${BPN}-${PV}.tar.gz
PR = "r6"
-inherit autotools pythonnative
+inherit autotools python3native
SRC_URI[md5sum] = "f7ca25ab3c88874015b7e9728f7f3017"
SRC_URI[sha256sum] = "244c0e1bf4bbd78ae298ea659fe10bf3a73738db550156767cc2477aedf72376"
diff --git a/meta-python/recipes-devtools/python-jsonref/python-jsonref.inc b/meta-python/recipes-devtools/python-jsonref/python-jsonref.inc
index 0e69e45345..45deb09c72 100644
--- a/meta-python/recipes-devtools/python-jsonref/python-jsonref.inc
+++ b/meta-python/recipes-devtools/python-jsonref/python-jsonref.inc
@@ -6,6 +6,6 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=a34264f25338d41744dca1abfe4eb18f"
SRC_URI[md5sum] = "42b518b9ccd6852d1d709749bc96cb70"
SRC_URI[sha256sum] = "f3c45b121cf6257eafabdc3a8008763aed1cd7da06dbabc59a9e4d2a5e4e6697"
-inherit pypi setuptools
+inherit pypi setuptools3
BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/pamela_0.3.0.bb b/meta-python/recipes-devtools/python/pamela_0.3.0.bb
index 030c22f8f3..b6bee0ca26 100644
--- a/meta-python/recipes-devtools/python/pamela_0.3.0.bb
+++ b/meta-python/recipes-devtools/python/pamela_0.3.0.bb
@@ -7,7 +7,7 @@ SRC_URI[sha256sum] = "1e198446a6cdd87704aa0def7621d62e7c20b0e6068e2788b9a866a835
PYPI_PACKAGE = "pamela"
-inherit pypi setuptools
+inherit pypi setuptools3
RDEPENDS_${PN} = "libpam"
diff --git a/meta-python/recipes-devtools/python/pyrtm_0.4.2.bb b/meta-python/recipes-devtools/python/pyrtm_0.4.2.bb
index 9d851abe33..798daeb212 100644
--- a/meta-python/recipes-devtools/python/pyrtm_0.4.2.bb
+++ b/meta-python/recipes-devtools/python/pyrtm_0.4.2.bb
@@ -8,7 +8,7 @@ PYPI_PACKAGE_EXT = "tar.bz2"
SRC_URI[md5sum] = "7c87da94656b620dfe532ca63d642eb8"
SRC_URI[sha256sum] = "b2d701b25ad3f9a1542057f3eb492c5c1d7dbe2b8d1e8f763043dcc14ee1d933"
-inherit pypi setuptools
+inherit pypi setuptools3
PACKAGES =+ "${PN}-tests ${PN}-samples"
diff --git a/meta-python/recipes-devtools/python/python-yappi.inc b/meta-python/recipes-devtools/python/python-yappi.inc
index 54d4087427..b3718d7d18 100644
--- a/meta-python/recipes-devtools/python/python-yappi.inc
+++ b/meta-python/recipes-devtools/python/python-yappi.inc
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://PKG-INFO;md5=9a193c13f346884e597acdcac7fe9ac8"
SRC_URI[md5sum] = "a545101aa8a435b0780f06f4723f58c8"
SRC_URI[sha256sum] = "7f814131515d51db62b1a3468bcb84de30499124752806a5a6e11caf0b4344bf"
-inherit pypi setuptools
+inherit pypi setuptools3
RDEPENDS_${PN} += "\
${PYTHON_PN}-datetime \
diff --git a/meta-python/recipes-devtools/python/python3-robotframework-seriallibrary_0.3.1.bb b/meta-python/recipes-devtools/python/python3-robotframework-seriallibrary_0.3.1.bb
index 440f69cbf7..d82b7b96ae 100644
--- a/meta-python/recipes-devtools/python/python3-robotframework-seriallibrary_0.3.1.bb
+++ b/meta-python/recipes-devtools/python/python3-robotframework-seriallibrary_0.3.1.bb
@@ -1,2 +1,2 @@
-inherit pypi setuptools
+inherit pypi setuptools3
require python-robotframework-seriallibrary.inc