aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-08-06 10:21:15 +0200
committerKhem Raj <raj.khem@gmail.com>2021-08-16 08:21:14 -0700
commitdbde7fc3cccedca7d6835c2bc1cb1055f9cb2284 (patch)
treeda2146f76a9622230acadc522d37e817a636e2c4 /meta-python
parent005ca8814ee4596c4cbc20edb08f333a1de7ead1 (diff)
downloadmeta-openembedded-contrib-dbde7fc3cccedca7d6835c2bc1cb1055f9cb2284.tar.gz
python3-grpcio: make sure that GRPC_CFLAGS is expanded to empty
* with bitbake change from: https://git.openembedded.org/bitbake/commit/?id=699e36c270d863258502d315ed00a1b940bfbf96 the GRPC_CFLAGS now stays None when toolchain-clang isn't used causing: i686-oe-linux-gcc: error: ${GRPC_CFLAGS}: linker input file not found: No such file or directory Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-grpcio_1.38.1.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-grpcio_1.38.1.bb b/meta-python/recipes-devtools/python/python3-grpcio_1.38.1.bb
index cbc8ce95fc..f68034763c 100644
--- a/meta-python/recipes-devtools/python/python3-grpcio_1.38.1.bb
+++ b/meta-python/recipes-devtools/python/python3-grpcio_1.38.1.bb
@@ -34,6 +34,7 @@ BORING_SSL:arm = "1"
BORING_SSL ?= "0"
export GRPC_BUILD_WITH_BORING_SSL_ASM = "${BORING_SSL}"
+GRPC_CFLAGS ?= ""
GRPC_CFLAGS:append:toolchain-clang = " -fvisibility=hidden -fno-wrapv -fno-exceptions"
export GRPC_PYTHON_CFLAGS = "${GRPC_CFLAGS}"