aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-06-23 12:06:01 +0300
committerKhem Raj <raj.khem@gmail.com>2021-06-24 12:54:18 -0700
commitb97c197421ceb5b2017f34b776c0f69644e248d5 (patch)
treee09037f3029070b6e450adef8f5ad96c9e64a6f2 /meta-python
parent226532a55cc1df0af70a97f93689b7566dade0cf (diff)
downloadmeta-openembedded-contrib-b97c197421ceb5b2017f34b776c0f69644e248d5.tar.gz
python3-pandas: Upgrade 1.2.4 -> 1.2.5
Upgrade to release 1.2.5: - Fixed regression in concat() between two DataFrame where one has an Index that is all-None and the other is DatetimeIndex incorrectly raising - Fixed regression in DataFrame.sum() and DataFrame.prod() when min_count and numeric_only are both given - Fixed regression in read_csv() when using memory_map=True with an non-UTF8 encoding - Fixed regression in DataFrame.replace() and Series.replace() when the values to replace is a NumPy float array - Fixed regression in ExcelFile() when a corrupt file is opened but not closed - Fixed regression in DataFrame.astype() with dtype=str failing to convert NaN in categorical columns Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-pandas_1.2.5.bb (renamed from meta-python/recipes-devtools/python/python3-pandas_1.2.4.bb)3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pandas_1.2.4.bb b/meta-python/recipes-devtools/python/python3-pandas_1.2.5.bb
index 54fa910a98..71386dc94a 100644
--- a/meta-python/recipes-devtools/python/python3-pandas_1.2.4.bb
+++ b/meta-python/recipes-devtools/python/python3-pandas_1.2.5.bb
@@ -6,7 +6,7 @@ HOMEPAGE = "http://pandas.pydata.org/"
LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://LICENSE;md5=c2a8f987b2ce77c368c6b3e1b5b10774"
-SRC_URI[sha256sum] = "649ecab692fade3cbfcf967ff936496b0cfba0af00a55dfaacd82bdda5cb2279"
+SRC_URI[sha256sum] = "14abb8ea73fce8aebbb1fb44bec809163f1c55241bcc1db91c2c780e97265033"
inherit pypi setuptools3
@@ -21,4 +21,5 @@ RDEPENDS_${PN} += " \
${PYTHON_PN}-numpy \
${PYTHON_PN}-dateutil \
${PYTHON_PN}-pytz \
+ ${PYTHON_PN}-profile \
"