aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@fujitsu.com>2021-08-02 11:38:56 +0800
committerKhem Raj <raj.khem@gmail.com>2021-08-03 08:52:32 -0700
commit80957c276a7b8288172b544338b0bf88050a9540 (patch)
tree27f6054e4f205ff2660c500ed5af99e58fc85e10 /meta-python
parent45edb9c4c9275071bf56c871ef34be4440dc5b64 (diff)
downloadmeta-openembedded-contrib-80957c276a7b8288172b544338b0bf88050a9540.tar.gz
python3-pandas: upgrade 1.3.0 -> 1.3.1
Fixed regressions Pandas could not be built on PyPy (GH42355) DataFrame constructed with an older version of pandas could not be unpickled (GH42345) Performance regression in constructing a DataFrame from a dictionary of dictionaries (GH42248) Fixed regression in DataFrame.agg() dropping values when the DataFrame had an Extension Array dtype, a duplicate index, and axis=1 (GH42380) Fixed regression in DataFrame.astype() changing the order of noncontiguous data (GH42396) Performance regression in DataFrame in reduction operations requiring casting such as DataFrame.mean() on integer data (GH38592) Performance regression in DataFrame.to_dict() and Series.to_dict() when orient argument one of “records”, “dict”, or “split” (GH42352) Fixed regression in indexing with a list subclass incorrectly raising TypeError (GH42433, GH42461) Fixed regression in DataFrame.isin() and Series.isin() raising TypeError with nullable data containing at least one missing value (GH42405) Regression in concat() between objects with bool dtype and integer dtype casting to object instead of to integer (GH42092) Bug in Series constructor not accepting a dask.Array (GH38645) Fixed regression for SettingWithCopyWarning displaying incorrect stacklevel (GH42570) Fixed regression for merge_asof() raising KeyError when one of the by columns is in the index (GH34488) Fixed regression in to_datetime() returning pd.NaT for inputs that produce duplicated values, when cache=True (GH42259) Fixed regression in SeriesGroupBy.value_counts() that resulted in an IndexError when called on a Series with one row (GH42618) Bug fixes Fixed bug in DataFrame.transpose() dropping values when the DataFrame had an Extension Array dtype and a duplicate index (GH42380) Fixed bug in DataFrame.to_xml() raising KeyError when called with index=False and an offset index (GH42458) Fixed bug in Styler.set_sticky() not handling index names correctly for single index columns case (GH42537) Fixed bug in DataFrame.copy() failing to consolidate blocks in the result (GH42579) Signed-off-by: Zang Ruochen <zangrc.fnst@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-pandas_1.3.1.bb (renamed from meta-python/recipes-devtools/python/python3-pandas_1.3.0.bb)2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pandas_1.3.0.bb b/meta-python/recipes-devtools/python/python3-pandas_1.3.1.bb
index b98e2865c7..02e21e4f83 100644
--- a/meta-python/recipes-devtools/python/python3-pandas_1.3.0.bb
+++ b/meta-python/recipes-devtools/python/python3-pandas_1.3.1.bb
@@ -6,7 +6,7 @@ HOMEPAGE = "http://pandas.pydata.org/"
LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://LICENSE;md5=3f23c5c092b74d245d48eeef72bc3fd2"
-SRC_URI[sha256sum] = "c554e6c9cf2d5ea1aba5979cc837b3649539ced0e18ece186f055450c86622e2"
+SRC_URI[sha256sum] = "341935a594db24f3ff07d1b34d1d231786aa9adfa84b76eab10bf42907c8aed3"
inherit pypi setuptools3