aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-06-23 12:06:02 +0300
committerKhem Raj <raj.khem@gmail.com>2021-06-24 12:54:18 -0700
commit262a13ea72fbae3eaa625c21e9ce728a3a70aa81 (patch)
treeb7b240de11d227dd01319c5ac0d8fe14ecfee94e /meta-python
parentb97c197421ceb5b2017f34b776c0f69644e248d5 (diff)
downloadmeta-openembedded-contrib-262a13ea72fbae3eaa625c21e9ce728a3a70aa81.tar.gz
python3-mypy: Upgrade 0.902 -> 0.910
Upgrade to release 0.910: - Call get_method_hook when methods are used in decorators - Don't ask to install a stub package if stubs are installed - [mypyc] Support various number-related dunders - Fix crash when inferring multiple assignment with overloaded function - Replace variable annotation with type comment to fix Python 3.5 - docs: updating URL in comment Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-mypy_0.910.bb (renamed from meta-python/recipes-devtools/python/python3-mypy_0.902.bb)11
1 files changed, 4 insertions, 7 deletions
diff --git a/meta-python/recipes-devtools/python/python3-mypy_0.902.bb b/meta-python/recipes-devtools/python/python3-mypy_0.910.bb
index 86465e2f3a..8e675e6a9b 100644
--- a/meta-python/recipes-devtools/python/python3-mypy_0.902.bb
+++ b/meta-python/recipes-devtools/python/python3-mypy_0.910.bb
@@ -3,21 +3,18 @@ HOMEPAGE = "https://github.com/python/mypy"
LICENSE = "MIT & Python-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=17b7180fcfc43c4e70c07c71588604c4"
-RDEPENDS_${PN} = " \
- ${PYTHON_PN}-mypy-extensions \
- ${PYTHON_PN}-typed-ast \
- ${PYTHON_PN}-typing-extensions \
-"
-
PYPI_PACKAGE = "mypy"
inherit pypi setuptools3
-SRC_URI[sha256sum] = "9236c21194fde5df1b4d8ebc2ef2c1f2a5dc7f18bcbea54274937cae2e20a01c"
+SRC_URI[sha256sum] = "704098302473cb31a218f1775a873b376b30b4c18229421e9e9dc8916fd16150"
BBCLASSEXTEND = "native"
RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-mypy-extensions \
+ ${PYTHON_PN}-typed-ast \
+ ${PYTHON_PN}-typing-extensions \
${PYTHON_PN}-json \
${PYTHON_PN}-compression \
${PYTHON_PN}-pprint \