aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-10-12 23:19:39 -0700
committerKhem Raj <raj.khem@gmail.com>2021-10-14 07:15:37 -0700
commitc0113a4afabe7be18c2898f87e9ceca1e4c7253e (patch)
tree1f70c3b1681a74cdafb36b339284287ee5a913f5 /meta-python
parentbf9c1d7b2e0f1fd3345c69a5d352a3fe2f86262f (diff)
downloadmeta-openembedded-contrib-c0113a4afabe7be18c2898f87e9ceca1e4c7253e.tar.gz
python3-parse-type: Do not ask for 2to3
It seems to work fine with py3 Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-parse-type_0.5.2.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-parse-type_0.5.2.bb b/meta-python/recipes-devtools/python/python3-parse-type_0.5.2.bb
index 39812a17cd..7eebbfb503 100644
--- a/meta-python/recipes-devtools/python/python3-parse-type_0.5.2.bb
+++ b/meta-python/recipes-devtools/python/python3-parse-type_0.5.2.bb
@@ -19,6 +19,11 @@ RDEPENDS:${PN}-ptest += " \
${PYTHON_PN}-pytest \
"
+do_configure:prepend() {
+ sed -i -e "/python_version >= 3.0/d" ${S}/setup.py
+ sed -i -e "/use_2to3/d" ${S}/setup.py
+}
+
do_install_ptest() {
install -d ${D}${PTEST_PATH}/tests
cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/