aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-10-13 08:26:11 -0700
committerKhem Raj <raj.khem@gmail.com>2021-10-14 07:15:37 -0700
commit6cf292602b63b35ff750e9150687fa6744f27a17 (patch)
treefd17f6449464dc01d5bf4e9523a004e2f74ae7db /meta-python
parentc0113a4afabe7be18c2898f87e9ceca1e4c7253e (diff)
downloadmeta-openembedded-contrib-6cf292602b63b35ff750e9150687fa6744f27a17.tar.gz
python3-anyjson: Do not enable 2to3
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-anyjson/0001-setup.py-Do-not-use-2to3.patch29
-rw-r--r--meta-python/recipes-devtools/python/python3-anyjson_0.3.3.bb1
2 files changed, 30 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-anyjson/0001-setup.py-Do-not-use-2to3.patch b/meta-python/recipes-devtools/python/python3-anyjson/0001-setup.py-Do-not-use-2to3.patch
new file mode 100644
index 0000000000..2b9e6e52e8
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-anyjson/0001-setup.py-Do-not-use-2to3.patch
@@ -0,0 +1,29 @@
+From 4fb61d7c621599b0db9c2c45f4243f07936c5953 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Wed, 13 Oct 2021 08:20:00 -0700
+Subject: [PATCH] setup.py: Do not use 2to3
+
+This helps compiling with setuptools 0.58+
+and it seems to compile fine with python3
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ setup.py | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index 9fe4902..f2098e1 100644
+--- a/setup.py
++++ b/setup.py
+@@ -2,8 +2,6 @@ import os
+ import sys
+
+ extra = {}
+-if sys.version_info >= (3, 0):
+- extra.update(use_2to3=True)
+
+ try:
+ from setuptools import setup, find_packages
+--
+2.33.0
+
diff --git a/meta-python/recipes-devtools/python/python3-anyjson_0.3.3.bb b/meta-python/recipes-devtools/python/python3-anyjson_0.3.3.bb
index 07cc99860d..2b8abb8b80 100644
--- a/meta-python/recipes-devtools/python/python3-anyjson_0.3.3.bb
+++ b/meta-python/recipes-devtools/python/python3-anyjson_0.3.3.bb
@@ -8,6 +8,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=989aa97e73c912a83a3c873fa11deb08"
inherit pypi setuptools3 ptest
SRC_URI += " \
+ file://0001-setup.py-Do-not-use-2to3.patch \
file://run-ptest \
"