aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorzhengruoqin <zhengrq.fnst@fujitsu.com>2021-10-27 22:32:13 +0800
committerKhem Raj <raj.khem@gmail.com>2021-10-28 09:01:25 -0700
commit35b64a4614435646c25740db9a58812f09e90c8e (patch)
treed7d34ebff76a5b4edf3bd9750f97141f3e4c2124 /meta-python
parent5a4a345ebd49951e89a04b2f17b16224db9367fa (diff)
downloadmeta-openembedded-contrib-35b64a4614435646c25740db9a58812f09e90c8e.tar.gz
python3-greenlet: upgrade 1.1.1 -> 1.1.2
1.1.2 (2021-09-29) ================== - Fix a potential crash due to a reference counting error when Python subclasses of ``greenlet.greenlet`` were deallocated. The crash became more common on Python 3.10; on earlier versions, silent memory corruption could result. See `issue 245 <https://github.com/python-greenlet/greenlet/issues/245>`_. Patch by fygao-wish. - Fix a leak of a list object when the last reference to a greenlet was deleted from some other thread than the one to which it belonged. For this to work correctly, you must call a greenlet API like ``getcurrent()`` before the thread owning the greenlet exits: this is a long-standing limitation that can also lead to the leak of a thread's main greenlet if not called; we hope to lift this limitation. Note that in some cases this may also fix leaks of greenlet objects themselves. See `issue 251 <https://github.com/python-greenlet/greenlet/issues/251>`_. - Python 3.10: Tracing or profiling into a spawned greenlet didn't work as expected. See `issue 256 <https://github.com/python-greenlet/greenlet/issues/256>`_, reported by Joe Rickerby. Signed-off-by: Zheng Ruoqin <zhengrq.fnst@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-greenlet_1.1.2.bb (renamed from meta-python/recipes-devtools/python/python3-greenlet_1.1.1.bb)2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-greenlet_1.1.1.bb b/meta-python/recipes-devtools/python/python3-greenlet_1.1.2.bb
index 9d014ec7a7..07c1436bfa 100644
--- a/meta-python/recipes-devtools/python/python3-greenlet_1.1.1.bb
+++ b/meta-python/recipes-devtools/python/python3-greenlet_1.1.2.bb
@@ -4,6 +4,6 @@ LICENSE = "MIT & PSF"
LIC_FILES_CHKSUM = "file://LICENSE;md5=e95668d68e4329085c7ab3535e6a7aee \
file://LICENSE.PSF;md5=c106931d9429eda0492617f037b8f69a"
-SRC_URI[sha256sum] = "c0f22774cd8294078bdf7392ac73cf00bfa1e5e0ed644bd064fdabc5f2a2f481"
+SRC_URI[sha256sum] = "e30f5ea4ae2346e62cedde8794a56858a67b878dd79f7df76a0767e356b1744a"
inherit pypi distutils3 setuptools3