aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-01-18 19:30:06 +0200
committerKhem Raj <raj.khem@gmail.com>2021-01-20 09:27:59 -0800
commit7599690d9c41085c8ab37b87a7dbddafbe5e6279 (patch)
treefe51bb5088d579f2ee238acbe6dadeb70950e37c /meta-python
parente31d5970cbc90ccc265f046577e019481a3141e6 (diff)
downloadmeta-openembedded-contrib-7599690d9c41085c8ab37b87a7dbddafbe5e6279.tar.gz
python3-greenlet: Upgrade 0.4.17 -> 1.0.0
Upgrade to release 1.0.0: - Add the ability to set a greenlet's PEP 567 contextvars context directly, by assigning to the greenlet's gr_context attribute. This restores support for some patterns of using greenlets atop an async environment that became more challenging in 0.4.17. - The repr of greenlet objects now includes extra information about its state. This is purely informative and the details are subject to change. - The greenlet module is now a package. There are no API changes, so all existing imports, including from C code, should continue to work. - (C API) The undocumented GREENLET_VERSION macro that defined a string giving the greenlet version is now deprecated and will not be updated. - Fix %s and %r formatting of a greenlet on Python 2. Previously it would result in a Unicode string instead of a native string. - Move continuous integration from Travis CI to Github Actions. License-Update: move to the src/ layout and this affects the note in LICENSE about Stackless Python Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-greenlet_0.4.17.bb9
-rw-r--r--meta-python/recipes-devtools/python/python3-greenlet_1.0.0.bb8
2 files changed, 8 insertions, 9 deletions
diff --git a/meta-python/recipes-devtools/python/python3-greenlet_0.4.17.bb b/meta-python/recipes-devtools/python/python3-greenlet_0.4.17.bb
deleted file mode 100644
index 744265e1fa..0000000000
--- a/meta-python/recipes-devtools/python/python3-greenlet_0.4.17.bb
+++ /dev/null
@@ -1,9 +0,0 @@
-SUMMARY = "Python lightweight in-process concurrent programming"
-LICENSE = "MIT & PSF"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=03143d7a1a9f5d8a0fee825f24ca9c36 \
- file://LICENSE.PSF;md5=c106931d9429eda0492617f037b8f69a"
-
-SRC_URI[md5sum] = "d964c95c2d2f0f02f36c75e158d8e3dc"
-SRC_URI[sha256sum] = "41d8835c69a78de718e466dd0e6bfd4b46125f21a67c3ff6d76d8d8059868d6b"
-
-inherit pypi distutils3
diff --git a/meta-python/recipes-devtools/python/python3-greenlet_1.0.0.bb b/meta-python/recipes-devtools/python/python3-greenlet_1.0.0.bb
new file mode 100644
index 0000000000..32194dba78
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-greenlet_1.0.0.bb
@@ -0,0 +1,8 @@
+SUMMARY = "Python lightweight in-process concurrent programming"
+LICENSE = "MIT & PSF"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e95668d68e4329085c7ab3535e6a7aee \
+ file://LICENSE.PSF;md5=c106931d9429eda0492617f037b8f69a"
+
+SRC_URI[sha256sum] = "719e169c79255816cdcf6dccd9ed2d089a72a9f6c42273aae12d55e8d35bdcf8"
+
+inherit pypi distutils3 setuptools3