aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@arm.com>2022-02-25 11:06:27 +0000
committerKhem Raj <raj.khem@gmail.com>2022-02-25 13:00:14 -0800
commitf7112f5b6fc23ec8a88d2abd4f3e061460c3ef40 (patch)
tree5cc5ca329d7f82b6c05e992679c5ab65f2fdec45 /meta-python
parentcfabc986f40051e95ee48755c26f7057430df942 (diff)
downloadmeta-openembedded-contrib-f7112f5b6fc23ec8a88d2abd4f3e061460c3ef40.tar.gz
layer.conf: change layer priority to match oe-core
Layer priority is the ultimate decider of what recipe is used: if layer A has recipe foo_1 and layer B has recipe foo_2, if layer A's priority is higher than B then foo_1 will be used, even though the version in B is higher, and even if PREFERRED_VERSION_foo is set to 2. This complicates recipes moving between layers, for example when a newer version of a recipe (say, python3-wheel) is taken from a layer with a higher priority (say, meta-python) and moved to a layer with a lower priority (say, oe-core) then it has to be removed before it is added: there is no way to have it in both layers and work correctly. Higher priorities are useful in distribution layers where you may want to override specific recipes without any other fuss. However as all of the layers in meta-oe simply add more recipes in defined areas, there's no need to have a higher layer priority. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/conf/layer.conf2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-python/conf/layer.conf b/meta-python/conf/layer.conf
index 98f734152f..e444498ff0 100644
--- a/meta-python/conf/layer.conf
+++ b/meta-python/conf/layer.conf
@@ -6,7 +6,7 @@ BBFILES += "${LAYERDIR}/recipes*/*/*.bb ${LAYERDIR}/recipes*/*/*.bbappend"
BBFILE_COLLECTIONS += "meta-python"
BBFILE_PATTERN_meta-python := "^${LAYERDIR}/"
-BBFILE_PRIORITY_meta-python = "7"
+BBFILE_PRIORITY_meta-python = "5"
# This should only be incremented on significant changes that will
# cause compatibility issues with other layers