aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@cold-front.org>2022-02-15 14:49:30 -0500
committerKhem Raj <raj.khem@gmail.com>2022-02-16 08:13:29 -0800
commita97e33665d3eaef70f8771918fad6f6f88ccf20f (patch)
treeff060d5d18fbd08349634c56ff95e111a13e97ed /meta-python
parent1d20c5964095623379346072b0757d028502e430 (diff)
downloadmeta-openembedded-contrib-a97e33665d3eaef70f8771918fad6f6f88ccf20f.tar.gz
python3-pytest-forked: add 1.4.0
Adding as a dependency of python3-pytest-xdist (which allows parallel execution of pytest test cases). Signed-off-by: Justin Bronder <jsbronder@cold-front.org> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-pytest-forked_1.4.0.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pytest-forked_1.4.0.bb b/meta-python/recipes-devtools/python/python3-pytest-forked_1.4.0.bb
new file mode 100644
index 0000000000..c6f352bc61
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pytest-forked_1.4.0.bb
@@ -0,0 +1,15 @@
+SUMMARY = "run tests in isolated forked subprocesses"
+HOMEPAGE = "https://github.com/pytest-dev/pytest-forked"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=772fcdaca14b378878d05c7d857e6c3e"
+
+SRC_URI[sha256sum] = "8b67587c8f98cbbadfdd804539ed5455b6ed03802203485dd2f53c1422d7440e"
+
+inherit pypi setuptools3
+
+DEPENDS += "python3-setuptools-scm-native"
+
+RDEPENDS:${PN} += " \
+ python3-py \
+ python3-pytest \
+"