aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2022-02-22 13:15:45 -0800
committerKhem Raj <raj.khem@gmail.com>2022-02-24 08:30:26 -0800
commit1c53fcca6e3a940188b1a6a3fb909fee02e36b90 (patch)
tree1832f4eb3df04919588463b627848386af471918 /meta-python
parentc720dc971befa080f489d5bcf27eb50a0bb37031 (diff)
downloadmeta-openembedded-contrib-1c53fcca6e3a940188b1a6a3fb909fee02e36b90.tar.gz
python3-test-generator: drop recipe
python3-nose still contains Python 2 code which causes errors in do_compile when using bdist_wheel or PEP-517 packaging. Like nose, test-generator has not been touched since 2016. Drop this recipe unless someone fixes the issues in python3-nose [YOCTO #14638] Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-test-generator/run-ptest3
-rw-r--r--meta-python/recipes-devtools/python/python3-test-generator_0.1.2.bb29
3 files changed, 0 insertions, 34 deletions
diff --git a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
index a8a09b4d56..d90e6551e7 100644
--- a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
+++ b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
@@ -424,7 +424,6 @@ RDEPENDS:packagegroup-meta-python3 = "\
python3-tabulate \
python3-term \
python3-termcolor \
- python3-test-generator \
python3-textparser \
python3-texttable \
python3-thrift \
@@ -535,7 +534,6 @@ RDEPENDS:packagegroup-meta-python3-ptest = "\
python3-smpplib-ptest \
python3-soupsieve-ptest \
python3-sqlparse-ptest \
- python3-test-generator-ptest \
python3-typeguard-ptest \
python3-ujson-ptest \
python3-u-msgpack-python-ptest \
diff --git a/meta-python/recipes-devtools/python/python3-test-generator/run-ptest b/meta-python/recipes-devtools/python/python3-test-generator/run-ptest
deleted file mode 100644
index 5cec711696..0000000000
--- a/meta-python/recipes-devtools/python/python3-test-generator/run-ptest
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/sh
-
-pytest
diff --git a/meta-python/recipes-devtools/python/python3-test-generator_0.1.2.bb b/meta-python/recipes-devtools/python/python3-test-generator_0.1.2.bb
deleted file mode 100644
index 7f212ddd87..0000000000
--- a/meta-python/recipes-devtools/python/python3-test-generator_0.1.2.bb
+++ /dev/null
@@ -1,29 +0,0 @@
-SUMMARY = "Generator is a helper for generating test methods for nose while still using unittest."
-DESCRIPTION = "Python package with modified subclasses of all stdlib XML \
-parsers that prevent any potentially malicious operation."
-
-LICENSE = "ISC"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=041a2bff595d40ccb4b36356f89dab00"
-
-SRC_URI += " \
- file://run-ptest \
-"
-
-SRC_URI[md5sum] = "6c69e73ba5b4b3ed62f7bcda071c64f1"
-SRC_URI[sha256sum] = "ad5925c814bfe79497b43df096e3bb52c166d1577f7aff160137301676232f4a"
-
-inherit pypi setuptools3 ptest
-
-RDEPENDS:${PN}-ptest += " \
- ${PYTHON_PN}-pytest \
- ${PYTHON_PN}-mock \
-"
-
-do_install_ptest() {
- install -d ${D}${PTEST_PATH}/tests
- cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
-}
-
-DEPENDS += "python3-nose-native"
-
-RDEPENDS:${PN} += "python3-six"