aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2016-07-04 16:06:15 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2016-07-22 21:45:31 +0200
commita9b7ae5427ea2dc0fe24154eef8d841e6bbe7a56 (patch)
tree7d42f4a746125481036bf12443290aa8a0b606ce /meta-python
parent45baacbbcf50f7d78e0a2adff6e0b174204f65f3 (diff)
downloadmeta-openembedded-contrib-a9b7ae5427ea2dc0fe24154eef8d841e6bbe7a56.tar.gz
python-pytest-runner: Add python-pytest-runner bb
* Add python-pytest-runner bb as python-mccabe depends on python-pytest-runner Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Acked-by: Tim Orling (Intel OpenSource Technology Center) < Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-pytest-runner_2.8.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pytest-runner_2.8.bb b/meta-python/recipes-devtools/python/python-pytest-runner_2.8.bb
new file mode 100644
index 0000000000..a4685ec01f
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pytest-runner_2.8.bb
@@ -0,0 +1,14 @@
+SUMMARY = "Invoke py.test as distutils command with dependency resolution"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e38b971c2b4c33b978d1b9c9ece9ae63"
+
+SRC_URI[md5sum] = "041f3624f450d87a242e3907d7f90e8f"
+SRC_URI[sha256sum] = "1ec44deddaa551f85fd563c40a4c483a2609aca1f284a95399566a74d0680d5c"
+PYPI_PACKAGE_HASH = "466cff61a9e0d513222afa3529bdb565a465812b7e50b218a5afd705f46b258c"
+
+DEPENDS += " \
+ python-setuptools-scm"
+
+RDEPENDS_${PN} = "python-py python-setuptools python-argparse python-debugger python-json"
+
+inherit pypi setuptools