aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-04-05 16:42:14 -0400
committerKhem Raj <raj.khem@gmail.com>2020-04-05 14:27:45 -0700
commit017ee6cb0b91367118f982d0564c69a91803e5b0 (patch)
tree64c3587a9bbe5fd9569921c44dd20c08d57aa2b9 /meta-python
parentf5c4819e53cadd872bacce065a6e9c5fd4721e8c (diff)
downloadmeta-openembedded-contrib-017ee6cb0b91367118f982d0564c69a91803e5b0.tar.gz
python-pycodestyle: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-pycodestyle.inc12
-rw-r--r--meta-python/recipes-devtools/python/python3-pycodestyle_2.5.0.bb14
2 files changed, 12 insertions, 14 deletions
diff --git a/meta-python/recipes-devtools/python/python-pycodestyle.inc b/meta-python/recipes-devtools/python/python-pycodestyle.inc
deleted file mode 100644
index 96cdc5deeb..0000000000
--- a/meta-python/recipes-devtools/python/python-pycodestyle.inc
+++ /dev/null
@@ -1,12 +0,0 @@
-SUMMARY = "Python style guide checker (formly called pep8)"
-HOMEPAGE = "https://pypi.org/project/pycodestyle"
-LICENSE = "MIT"
-SECTION = "devel/python"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=01831ddbaf398471da3cc87f5037e822"
-
-SRC_URI[md5sum] = "40e7a76f364a18f531aaba11a4476e21"
-SRC_URI[sha256sum] = "e40a936c9a450ad81df37f549d676d127b1b66000a6c500caa2b085bc0ca976c"
-
-inherit pypi
-
-BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python3-pycodestyle_2.5.0.bb b/meta-python/recipes-devtools/python/python3-pycodestyle_2.5.0.bb
index cedcdb3bf8..7f00ab6291 100644
--- a/meta-python/recipes-devtools/python/python3-pycodestyle_2.5.0.bb
+++ b/meta-python/recipes-devtools/python/python3-pycodestyle_2.5.0.bb
@@ -1,2 +1,12 @@
-inherit setuptools3
-require python-pycodestyle.inc
+SUMMARY = "Python style guide checker (formly called pep8)"
+HOMEPAGE = "https://pypi.org/project/pycodestyle"
+LICENSE = "MIT"
+SECTION = "devel/python"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=01831ddbaf398471da3cc87f5037e822"
+
+SRC_URI[md5sum] = "40e7a76f364a18f531aaba11a4476e21"
+SRC_URI[sha256sum] = "e40a936c9a450ad81df37f549d676d127b1b66000a6c500caa2b085bc0ca976c"
+
+inherit pypi setuptools3
+
+BBCLASSEXTEND = "native nativesdk"