aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-03-26 15:12:27 +0200
committerKhem Raj <raj.khem@gmail.com>2021-03-30 09:04:34 -0700
commitc42a7b7d973bd4c3b5c4c1dc029edad6efbd397c (patch)
treed7b300a3af8375ed147cac20b52c52ce00d0ebf9 /meta-python
parent02feb1d9324fba08c5d3055fa34bb6200ee91520 (diff)
downloadmeta-openembedded-contrib-c42a7b7d973bd4c3b5c4c1dc029edad6efbd397c.tar.gz
python3-ruamel-yaml: Upgrade 0.16.13 -> 0.17.0
Upgrade to release 0.17.0: - this release no longer supports Python 2.7, most if not all Python 2 specific code is removed. The 0.17.x series is the last to support Python 3.5 (this also allowed for removal of the dependency on ``ruamel.std.pathlib``) - remove Python2 specific code branches and adaptations (u-strings) - prepare % code for f-strings using ``_F`` - allow PyOxidisation - replaced Python 2 compatible enforcement of keyword arguments with '*' - the old top level *functions* ``load``, ``safe_load``, ``round_trip_load``, ``dump``, ``safe_dump``, ``round_trip_dump``, ``scan``, ``parse``, ``compose``, ``emit``, ``serialize`` as well as their ``_all`` variants for multi-document streams, now issue a ``PendingDeprecationning`` (e.g. when run from pytest, but also Python is started with ``-Wd``). Use the methods on ``YAML()``, which have been extended. - fix for issue 376: indentation changes could put literal/folded scalar to start before the ``#`` column of a following comment. Effectively making the comment part of the scalar in the output. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-ruamel-yaml_0.17.0.bb (renamed from meta-python/recipes-devtools/python/python3-ruamel-yaml_0.16.13.bb)2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-ruamel-yaml_0.16.13.bb b/meta-python/recipes-devtools/python/python3-ruamel-yaml_0.17.0.bb
index 39795b7847..fd99f8566f 100644
--- a/meta-python/recipes-devtools/python/python3-ruamel-yaml_0.16.13.bb
+++ b/meta-python/recipes-devtools/python/python3-ruamel-yaml_0.17.0.bb
@@ -10,7 +10,7 @@ inherit pypi setuptools3
BBCLASSEXTEND = "native nativesdk"
-SRC_URI[sha256sum] = "bb48c514222702878759a05af96f4b7ecdba9b33cd4efcf25c86b882cef3a942"
+SRC_URI[sha256sum] = "3572505e63dd35b5dea62cd0386d03c4f2a53da29a3af09f428114cc85c564aa"
do_install_prepend() {
export RUAMEL_NO_PIP_INSTALL_CHECK=1