aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-04-05 16:42:13 -0400
committerKhem Raj <raj.khem@gmail.com>2020-04-05 14:27:45 -0700
commitf5c4819e53cadd872bacce065a6e9c5fd4721e8c (patch)
tree648de241e9725f9448eb31fd67ccb57ea5963487 /meta-python
parentfb8ddbfe2531d6b1a848c755920cbb13ce67e691 (diff)
downloadmeta-openembedded-contrib-f5c4819e53cadd872bacce065a6e9c5fd4721e8c.tar.gz
python-pycparser: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-pycparser.inc17
-rw-r--r--meta-python/recipes-devtools/python/python3-pycparser_2.19.bb17
2 files changed, 15 insertions, 19 deletions
diff --git a/meta-python/recipes-devtools/python/python-pycparser.inc b/meta-python/recipes-devtools/python/python-pycparser.inc
deleted file mode 100644
index 47a0e0e973..0000000000
--- a/meta-python/recipes-devtools/python/python-pycparser.inc
+++ /dev/null
@@ -1,17 +0,0 @@
-SUMMARY = "Parser of the C language, written in pure Python"
-HOMEPAGE = "https://github.com/eliben/pycparser"
-LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=86f1cedb4e6410a88ce8e30b91079169"
-
-SRC_URI[md5sum] = "76396762adc3fa769c83d8e202d36b6f"
-SRC_URI[sha256sum] = "a988718abfad80b6b157acce7bf130a30876d27603738ac39f140993246b25b3"
-
-
-BBCLASSEXTEND = "native nativesdk"
-
-RDEPENDS_${PN}_class-target += "\
- ${PYTHON_PN}-ply \
- ${PYTHON_PN}-pprint \
- cpp \
- cpp-symlinks \
- "
diff --git a/meta-python/recipes-devtools/python/python3-pycparser_2.19.bb b/meta-python/recipes-devtools/python/python3-pycparser_2.19.bb
index 7cc024ea09..35ed93e09b 100644
--- a/meta-python/recipes-devtools/python/python3-pycparser_2.19.bb
+++ b/meta-python/recipes-devtools/python/python3-pycparser_2.19.bb
@@ -1,6 +1,19 @@
+SUMMARY = "Parser of the C language, written in pure Python"
+HOMEPAGE = "https://github.com/eliben/pycparser"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86f1cedb4e6410a88ce8e30b91079169"
+
+SRC_URI[md5sum] = "76396762adc3fa769c83d8e202d36b6f"
+SRC_URI[sha256sum] = "a988718abfad80b6b157acce7bf130a30876d27603738ac39f140993246b25b3"
+
inherit pypi setuptools3
-require python-pycparser.inc
+
+BBCLASSEXTEND = "native nativesdk"
RDEPENDS_${PN}_class-target += "\
${PYTHON_PN}-netclient \
- "
+ ${PYTHON_PN}-ply \
+ ${PYTHON_PN}-pprint \
+ cpp \
+ cpp-symlinks \
+ "