aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorMichael Fitz-Payne <mfitz.payne@gmail.com>2020-08-21 08:53:27 +1000
committerKhem Raj <raj.khem@gmail.com>2020-08-25 10:36:15 -0700
commit9efe7a412db8c2df6bd81087a2c289d1c5b63262 (patch)
treea2555a8061571a58ec4bb398d59acd68fcac37ed /meta-python
parentfc1a921c89b3ec6366c8de958e30a9995ad9281b (diff)
downloadmeta-openembedded-contrib-9efe7a412db8c2df6bd81087a2c289d1c5b63262.tar.gz
python3-greenstalk: add recipe for greenstalk python package.
Greenstalk is a small and unopinionated Python client library for communicating with the beanstalkd work queue. The API provided mostly maps one-to-one with commands in the protocol. Signed-off-by: Michael Fitz-Payne <michael.fitz-payne@digi.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-greenstalk_1.0.1.bb12
1 files changed, 12 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-greenstalk_1.0.1.bb b/meta-python/recipes-devtools/python/python3-greenstalk_1.0.1.bb
new file mode 100644
index 0000000000..9447c18363
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-greenstalk_1.0.1.bb
@@ -0,0 +1,12 @@
+SUMMARY = "A Python 3 client for the beanstalkd work queue"
+HOMEPAGE = "https://github.com/mayhewj/greenstalk"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=8f98432ba1fce3933c556430fd47298f"
+
+SRC_URI[md5sum] = "3374649586a8016fecaf0ce5ecf9985d"
+SRC_URI[sha256sum] = "0c9f2af79ac8ea526891ae8d7e9500341a0f657465a541d6eaedb35ff70f4fe3"
+
+RDEPENDS_${PN} += "python3-io python3-core"
+
+inherit pypi
+inherit setuptools3