aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-02-09 11:38:59 -0500
committerKhem Raj <raj.khem@gmail.com>2020-02-09 22:31:32 -0800
commit611b0c707aa889b1b3880687334b6dd0fd69479b (patch)
tree9a75e57777623f35c06ee428e53276aa118569bc /meta-python
parent365034834a1193d36c730d9eebb9a4dd1b8399fc (diff)
downloadmeta-openembedded-contrib-611b0c707aa889b1b3880687334b6dd0fd69479b.tar.gz
python3-alembic: update to version 1.4.0
Update license checksum for copyright change to 2020 Verified license remains MIT Consolidated inc & bb file for python3 only recipe Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-alembic.inc15
-rw-r--r--meta-python/recipes-devtools/python/python3-alembic_1.3.2.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-alembic_1.4.0.bb17
3 files changed, 17 insertions, 17 deletions
diff --git a/meta-python/recipes-devtools/python/python-alembic.inc b/meta-python/recipes-devtools/python/python-alembic.inc
deleted file mode 100644
index c94c142ddb..0000000000
--- a/meta-python/recipes-devtools/python/python-alembic.inc
+++ /dev/null
@@ -1,15 +0,0 @@
-DESCRIPTION = "A database migration tool for SQLAlchemy"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=28aaf14a6592d14dbfb2f4abd597aa27"
-
-SRC_URI[md5sum] = "3d7584a8fb0203ec82b90baa726d2bd9"
-SRC_URI[sha256sum] = "3b0cb1948833e062f4048992fbc97ecfaaaac24aaa0d83a1202a99fb58af8c6d"
-
-PYPI_PACKAGE = "alembic"
-
-RDEPENDS_${PN} += "\
- ${PYTHON_PN}-dateutil \
- ${PYTHON_PN}-editor \
- ${PYTHON_PN}-mako \
- ${PYTHON_PN}-sqlalchemy \
-"
diff --git a/meta-python/recipes-devtools/python/python3-alembic_1.3.2.bb b/meta-python/recipes-devtools/python/python3-alembic_1.3.2.bb
deleted file mode 100644
index e248fe7ce9..0000000000
--- a/meta-python/recipes-devtools/python/python3-alembic_1.3.2.bb
+++ /dev/null
@@ -1,2 +0,0 @@
-inherit pypi setuptools3
-require python-alembic.inc
diff --git a/meta-python/recipes-devtools/python/python3-alembic_1.4.0.bb b/meta-python/recipes-devtools/python/python3-alembic_1.4.0.bb
new file mode 100644
index 0000000000..8247166da6
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-alembic_1.4.0.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "A database migration tool for SQLAlchemy"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=bd64aba1b968c2bfbc2b525a181ce85c"
+
+inherit pypi setuptools3
+
+SRC_URI[md5sum] = "758b28361557e45c79c454d662131a83"
+SRC_URI[sha256sum] = "2df2519a5b002f881517693b95626905a39c5faf4b5a1f94de4f1441095d1d26"
+
+PYPI_PACKAGE = "alembic"
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-dateutil \
+ ${PYTHON_PN}-editor \
+ ${PYTHON_PN}-mako \
+ ${PYTHON_PN}-sqlalchemy \
+"