aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-06-12 12:47:56 +0300
committerKhem Raj <raj.khem@gmail.com>2020-06-13 21:34:21 -0700
commit180688cf301f2d045ad22ae9bd8d706476e50554 (patch)
treee023a954f01bb1c0e10ecc5782fb6112775f5e06 /meta-python
parent7b256be4ab7c1439c13256fa2d77e7f14c2b7184 (diff)
downloadmeta-openembedded-contrib-180688cf301f2d045ad22ae9bd8d706476e50554.tar.gz
python3-parse-type: Consolidate in a single file
Consolidate inc and bb files into a single bb file. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-parse-type.inc25
-rw-r--r--meta-python/recipes-devtools/python/python3-parse-type_0.4.2.bb27
2 files changed, 25 insertions, 27 deletions
diff --git a/meta-python/recipes-devtools/python/python-parse-type.inc b/meta-python/recipes-devtools/python/python-parse-type.inc
deleted file mode 100644
index 147ea6443f..0000000000
--- a/meta-python/recipes-devtools/python/python-parse-type.inc
+++ /dev/null
@@ -1,25 +0,0 @@
-SUMMARY = "Simplifies building parse types based on the parse module"
-HOMEPAGE = "https://github.com/jenisys/parse_type"
-LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=d07323820cca0f1d192cbbf8a0516f95"
-
-SRC_URI[md5sum] = "b5fa59e45965d1b2896023742df2e707"
-SRC_URI[sha256sum] = "f596bdc75d3dd93036fbfe3d04127da9f6df0c26c36e01e76da85adef4336b3c"
-
-PYPI_PACKAGE = "parse_type"
-inherit pypi ptest
-
-RDEPENDS_${PN} += "${PYTHON_PN}-parse"
-
-SRC_URI += " \
- file://run-ptest \
-"
-
-RDEPENDS_${PN}-ptest += " \
- ${PYTHON_PN}-pytest \
-"
-
-do_install_ptest() {
- install -d ${D}${PTEST_PATH}/tests
- cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
-}
diff --git a/meta-python/recipes-devtools/python/python3-parse-type_0.4.2.bb b/meta-python/recipes-devtools/python/python3-parse-type_0.4.2.bb
index 91d9ce2d43..a9e7a53ee1 100644
--- a/meta-python/recipes-devtools/python/python3-parse-type_0.4.2.bb
+++ b/meta-python/recipes-devtools/python/python3-parse-type_0.4.2.bb
@@ -1,2 +1,25 @@
-inherit setuptools3
-require python-parse-type.inc
+SUMMARY = "Simplifies building parse types based on the parse module"
+HOMEPAGE = "https://github.com/jenisys/parse_type"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=d07323820cca0f1d192cbbf8a0516f95"
+
+SRC_URI[md5sum] = "b5fa59e45965d1b2896023742df2e707"
+SRC_URI[sha256sum] = "f596bdc75d3dd93036fbfe3d04127da9f6df0c26c36e01e76da85adef4336b3c"
+
+PYPI_PACKAGE = "parse_type"
+inherit pypi ptest setuptools3
+
+RDEPENDS_${PN} += "${PYTHON_PN}-parse"
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}