aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2020-05-09 12:42:23 +0800
committerKhem Raj <raj.khem@gmail.com>2020-05-09 10:41:48 -0700
commit16b524d00a1f0684093b278a45f98fa736dda1e2 (patch)
tree1455aefa2aa84a42af120a14bc8f17de61102870 /meta-python
parentb34cb7ca8c2625ed9ab439dc50cf2ced0cc4571d (diff)
downloadmeta-openembedded-contrib-16b524d00a1f0684093b278a45f98fa736dda1e2.tar.gz
python3-zipp: add the missing rdepends
Add the missing rdepends to fix below error: # python3 [snip] >>> import zipp ModuleNotFoundError: No module named 'zipfile' ModuleNotFoundError: No module named 'random' python3-math Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-zipp_0.6.0.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-zipp_0.6.0.bb b/meta-python/recipes-devtools/python/python3-zipp_0.6.0.bb
index 1019081f38..40db3c071a 100644
--- a/meta-python/recipes-devtools/python/python3-zipp_0.6.0.bb
+++ b/meta-python/recipes-devtools/python/python3-zipp_0.6.0.bb
@@ -10,6 +10,8 @@ DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
inherit pypi setuptools3
-RDEPENDS_${PN} += "${PYTHON_PN}-more-itertools"
+RDEPENDS_${PN} += "${PYTHON_PN}-compression \
+ ${PYTHON_PN}-math \
+ ${PYTHON_PN}-more-itertools"
BBCLASSEXTEND = "native nativesdk"