aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorMax Krummenacher <max.oss.09@gmail.com>2017-02-14 22:48:58 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2017-02-16 12:06:36 +0100
commita8463f3eec26befedb57f400996c8aee44848244 (patch)
tree724fdd48a6bdc0b214f17350c84cb56594e711b1 /meta-python
parent7d8a81fd18be5e96c1c70e5951056daf03a167ed (diff)
downloadmeta-openembedded-contrib-a8463f3eec26befedb57f400996c8aee44848244.tar.gz
python-m2crypto: rdepend on python-typing
python-typing is required at runtime, not at build time. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-m2crypto_0.25.1.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python-m2crypto_0.25.1.bb b/meta-python/recipes-devtools/python/python-m2crypto_0.25.1.bb
index ca462229ea..72523bd7f0 100644
--- a/meta-python/recipes-devtools/python/python-m2crypto_0.25.1.bb
+++ b/meta-python/recipes-devtools/python/python-m2crypto_0.25.1.bb
@@ -12,7 +12,8 @@ SRC_URI += "file://0001-setup.py-link-in-sysroot-not-in-host-directories.patch "
PYPI_PACKAGE = "M2Crypto"
inherit pypi setuptools siteinfo
-DEPENDS += "openssl swig-native python-typing"
+DEPENDS += "openssl swig-native"
+RDEPENDS_${PN} += "python-typing"
DISTUTILS_BUILD_ARGS += "build_ext --openssl=${STAGING_DIR_HOST} -I${STAGING_INCDIR}"
DISTUTILS_INSTALL_ARGS += "build_ext --openssl=${STAGING_DIR_HOST}"