aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorSven Ebenfeld <sven.ebenfeld@gmail.com>2016-01-22 23:36:49 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-02-01 15:51:16 +0100
commit518234dbaabb57338166cbcaa8af163d9eb14ef6 (patch)
tree0acf17aae12c6204238f0ef48cdf8272a68f4dd7 /meta-python
parent1e049fbc1c771dface71a190600b2e63f5f4345c (diff)
downloadmeta-openembedded-contrib-518234dbaabb57338166cbcaa8af163d9eb14ef6.tar.gz
python-requests: 2.7.0 -> 2.9.1 and add python3 recipe
Signed-off-by: Sven Ebenfeld <sven.ebenfeld@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-requests.inc9
-rw-r--r--meta-python/recipes-devtools/python/python-requests_2.7.0.bb18
-rw-r--r--meta-python/recipes-devtools/python/python-requests_2.9.1.bb4
-rw-r--r--meta-python/recipes-devtools/python/python3-requests_2.9.1.bb2
4 files changed, 15 insertions, 18 deletions
diff --git a/meta-python/recipes-devtools/python/python-requests.inc b/meta-python/recipes-devtools/python/python-requests.inc
new file mode 100644
index 0000000000..ebce2539c9
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-requests.inc
@@ -0,0 +1,9 @@
+DESCRIPTION = "Python HTTP for Humans."
+HOMEPAGE = "http://python-requests.org"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=58c7e163c9f8ee037246da101c6afd1e"
+
+SRC_URI[md5sum] = "0b7f480d19012ec52bab78292efd976d"
+SRC_URI[sha256sum] = "c577815dd00f1394203fc44eb979724b098f88264a9ef898ee45b8e5e9cf587f"
+
+RDEPENDS_${PN} = "${PYTHON_PN}-email ${PYTHON_PN}-json ${PYTHON_PN}-netserver"
diff --git a/meta-python/recipes-devtools/python/python-requests_2.7.0.bb b/meta-python/recipes-devtools/python/python-requests_2.7.0.bb
deleted file mode 100644
index ac47202acc..0000000000
--- a/meta-python/recipes-devtools/python/python-requests_2.7.0.bb
+++ /dev/null
@@ -1,18 +0,0 @@
-DESCRIPTION = "Python HTTP for Humans."
-HOMEPAGE = "http://python-requests.org"
-SECTION = "devel/python"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=58c7e163c9f8ee037246da101c6afd1e"
-
-SRCNAME = "requests"
-
-SRC_URI = "http://pypi.python.org/packages/source/r/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
-
-SRC_URI[md5sum] = "29b173fd5fa572ec0764d1fd7b527260"
-SRC_URI[sha256sum] = "398a3db6d61899d25fd4a06c6ca12051b0ce171d705decd7ed5511517b4bb93d"
-
-S = "${WORKDIR}/${SRCNAME}-${PV}"
-
-inherit setuptools
-
-RDEPENDS_${PN} = "python-email python-json python-netserver python-zlib"
diff --git a/meta-python/recipes-devtools/python/python-requests_2.9.1.bb b/meta-python/recipes-devtools/python/python-requests_2.9.1.bb
new file mode 100644
index 0000000000..acc8c1665e
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-requests_2.9.1.bb
@@ -0,0 +1,4 @@
+inherit pypi
+require python-requests.inc
+
+RDEPENDS_${PN} += "${PYTHON_PN}-zlib" \ No newline at end of file
diff --git a/meta-python/recipes-devtools/python/python3-requests_2.9.1.bb b/meta-python/recipes-devtools/python/python3-requests_2.9.1.bb
new file mode 100644
index 0000000000..c2eb056eec
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-requests_2.9.1.bb
@@ -0,0 +1,2 @@
+inherit pypi3
+require python-requests.inc