aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorYuan Chao <yuanc.fnst@cn.fujitsu.com>2019-09-19 12:23:27 +0900
committerKhem Raj <raj.khem@gmail.com>2019-09-19 00:09:43 -0700
commit810f586371e16ba67d5b374670f16317a8550587 (patch)
treebfd0c068d052a91de4afd61fdace4bc420cdeb19 /meta-python
parent6ded1171019ef764f48dce1d7124b72d2c44e62c (diff)
downloadmeta-openembedded-contrib-810f586371e16ba67d5b374670f16317a8550587.tar.gz
python-pathlib2: new recipe
Add new recipe python-pathlib2 as it is RDEPEND of python-pytest. Signed-off-by: Yuan Chao <yuanc.fnst@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-pathlib2.inc9
-rw-r--r--meta-python/recipes-devtools/python/python-pathlib2_2.3.4.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-pathlib2_2.3.4.bb2
3 files changed, 13 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pathlib2.inc b/meta-python/recipes-devtools/python/python-pathlib2.inc
new file mode 100644
index 0000000000..c25e5a0807
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pathlib2.inc
@@ -0,0 +1,9 @@
+DESCRIPTION = "Object-oriented filesystem paths"
+HOMEPAGE = "https://github.com/mcmtroffaes/pathlib2"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=042856c23a3e903b33bf361ea1cbe29a"
+
+SRC_URI[md5sum] = "96da6398b3ea944417b84ccb25b171aa"
+SRC_URI[sha256sum] = "446014523bb9be5c28128c4d2a10ad6bb60769e78bd85658fe44a450674e0ef8"
+
+RDEPENDS_${PN} += "${PYTHON_PN}-six"
diff --git a/meta-python/recipes-devtools/python/python-pathlib2_2.3.4.bb b/meta-python/recipes-devtools/python/python-pathlib2_2.3.4.bb
new file mode 100644
index 0000000000..e4bf789131
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pathlib2_2.3.4.bb
@@ -0,0 +1,2 @@
+inherit pypi setuptools
+require python-pathlib2.inc
diff --git a/meta-python/recipes-devtools/python/python3-pathlib2_2.3.4.bb b/meta-python/recipes-devtools/python/python3-pathlib2_2.3.4.bb
new file mode 100644
index 0000000000..66f71e57a4
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pathlib2_2.3.4.bb
@@ -0,0 +1,2 @@
+inherit pypi setuptools3
+require python-pathlib2.inc