aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2022-04-19 16:13:54 +0300
committerTrevor Gamblin <tvgamblin@gmail.com>2022-04-22 16:26:22 +0000
commita1b80175b360f8f92a45df05528d382b0b03a8ba (patch)
treee137d7674239a9d5d7b455c55058d2a9e44576ab /meta-python
parent9881151e804d1a51203ad053a7a984aa1ba180d8 (diff)
downloadmeta-openembedded-contrib-a1b80175b360f8f92a45df05528d382b0b03a8ba.tar.gz
python3-marshmallow: Upgrade 3.14.1 -> 3.15.0
Upgrade to release 3.15.0: - Allow passing a dict to fields.Nested - Address distutils deprecation warning in Python 3.10 - Add py310 to black target-version - Drop support for Python 3.6 - Use postponed evaluation of annotations Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <tvgamblin@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-marshmallow_3.15.0.bb (renamed from meta-python/recipes-devtools/python/python3-marshmallow_3.14.1.bb)12
1 files changed, 10 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-marshmallow_3.14.1.bb b/meta-python/recipes-devtools/python/python3-marshmallow_3.15.0.bb
index dc5f173888..c8e0fa4dd3 100644
--- a/meta-python/recipes-devtools/python/python3-marshmallow_3.14.1.bb
+++ b/meta-python/recipes-devtools/python/python3-marshmallow_3.15.0.bb
@@ -9,7 +9,7 @@ LIC_FILES_CHKSUM = "\
SRC_URI = "git://github.com/marshmallow-code/marshmallow.git;protocol=https;branch=dev"
-SRCREV = "41afdefd93afd1b95f48f45fd284ff8add3e91b7"
+SRCREV = "f251dfb08d79c755c2e95371f2c5580bf5937e60"
S = "${WORKDIR}/git"
@@ -17,4 +17,12 @@ inherit setuptools3
PIP_INSTALL_PACKAGE = "marshmallow"
-RDEPENDS:${PN} += "python3-core"
+RDEPENDS:${PN} += " \
+ python3-core \
+ python3-datetime \
+ python3-netclient \
+ python3-numbers \
+ python3-json \
+ python3-pprint \
+ python3-packaging \
+"