aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-05-01 09:14:36 -0700
committerArmin Kuster <akuster808@gmail.com>2022-05-17 05:57:10 -0700
commit94ca1426931e91e452ffeb014e7158cc9ce850f8 (patch)
tree10f47b8cf2068f233bbb2e5e3cbba2adf4dad315 /meta-python
parent204fd35a3d9581fbf6493cde7a72c0aa2ba7beac (diff)
downloadmeta-openembedded-contrib-94ca1426931e91e452ffeb014e7158cc9ce850f8.tar.gz
python3-wxgtk4: Needs x11 for sip module
sip/cpp/sip_corewxWindow.cpp requires gdk/gdkx.h which wont be built when gtk is built without x11, therefore require x11 when building this recipe, if gdkx.h is removed form includes then it fails ../../../../sip/cpp/sip_corewxWindow.cpp:56:16: error: unknown type name 'XID' static XID GetXWindow(const wxWindow* wxwin) { ^ ../../../../sip/cpp/sip_corewxWindow.cpp:59:28: error: use of undeclared identifier 'GDK_WINDOW_XID' return GDK_WINDOW_XID(gtk_widget_get_window((wxwin)->m_wxwindow)); ^ ../../../../sip/cpp/sip_corewxWindow.cpp:64:28: error: use of undeclared identifier 'GDK_WINDOW_XID' return GDK_WINDOW_XID(gtk_widget_get_window((wxwin)->m_widget)); ^ so it is using it and will need some work to get it going without x11 until then disable building it on non-x11 distros Signed-off-by: Khem Raj <raj.khem@gmail.com> Cc: Robert Yang <liezhi.yang@windriver.com> (cherry picked from commit e347168b10a69febd106d758faf20d95c4bd8b62) Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.1.1.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.1.1.bb b/meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.1.1.bb
index 3583acc9cd..6ec92c2cec 100644
--- a/meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.1.1.bb
+++ b/meta-python/recipes-devtools/python3-wxgtk4/python3-wxgtk4_4.1.1.bb
@@ -18,7 +18,7 @@ S = "${WORKDIR}/wxPython-${PV}"
inherit pypi setuptools3 pkgconfig features_check
-ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
+REQUIRED_DISTRO_FEATURES = "x11"
export WX_CONFIG = "'${RECIPE_SYSROOT_NATIVE}${bindir}/wx-config --prefix=${STAGING_EXECPREFIXDIR} --baselib=${baselib}'"