aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2022-04-19 09:45:20 +0800
committerTrevor Gamblin <tvgamblin@gmail.com>2022-04-22 16:26:22 +0000
commit674306a4296dcbf869ae13302b230a502537d04b (patch)
treea4ff6ec2e4ac6b5347e6403ff68f70e3fbb2230b /meta-python
parentb3be90be2f6ad6a794df9cf756542434dde0888b (diff)
downloadmeta-openembedded-contrib-674306a4296dcbf869ae13302b230a502537d04b.tar.gz
python3-blivetgui: use symbolic list-add and edit- icons
Backport patch from upstream for python3-blivetgui to use symbolic list-add and edit- icons that Adwaita dropped old ones. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <tvgamblin@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-extended/python-blivet/python3-blivetgui/0002-Use-symbolic-list-add-and-edit-icons.patch56
-rw-r--r--meta-python/recipes-extended/python-blivet/python3-blivetgui_2.3.0.bb3
2 files changed, 58 insertions, 1 deletions
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivetgui/0002-Use-symbolic-list-add-and-edit-icons.patch b/meta-python/recipes-extended/python-blivet/python3-blivetgui/0002-Use-symbolic-list-add-and-edit-icons.patch
new file mode 100644
index 0000000000..3a95859ad7
--- /dev/null
+++ b/meta-python/recipes-extended/python-blivet/python3-blivetgui/0002-Use-symbolic-list-add-and-edit-icons.patch
@@ -0,0 +1,56 @@
+Upstream-Status: Backport [https://github.com/storaged-project/blivet-gui/commit/eb8ec968]
+
+Signed-off-by: Kai Kang <kai.kang@windriver.com>
+
+From eb8ec968d1ee8b4b710568b1eb8536296f90751e Mon Sep 17 00:00:00 2001
+From: Adam Williamson <awilliam@redhat.com>
+Date: Thu, 17 Feb 2022 11:16:22 -0800
+Subject: [PATCH] Use symbolic list-add and edit- icons (Adwaita dropped old
+ ones)
+
+adwaita-icon-theme 42 no longer includes the non-symbolic icons
+for these names. The choices are to switch to symbolic ones or
+carry the non-symbolic ones downstream.
+
+Signed-off-by: Adam Williamson <awilliam@redhat.com>
+---
+ blivetgui/list_actions.py | 8 ++++----
+ blivetgui/processing_window.py | 6 +++---
+ 2 files changed, 7 insertions(+), 7 deletions(-)
+
+diff --git a/blivetgui/list_actions.py b/blivetgui/list_actions.py
+index b7c1f9c..5388feb 100644
+--- a/blivetgui/list_actions.py
++++ b/blivetgui/list_actions.py
+@@ -48,10 +48,10 @@ def __init__(self, blivet_gui):
+ self.blivet_gui = blivet_gui
+
+ icon_theme = Gtk.IconTheme.get_default() # pylint: disable=no-value-for-parameter
+- icon_add = Gtk.IconTheme.load_icon(icon_theme, "list-add", 16, 0)
+- icon_delete = Gtk.IconTheme.load_icon(icon_theme, "edit-delete", 16, 0)
+- icon_edit = Gtk.IconTheme.load_icon(icon_theme, "edit-select-all", 16, 0)
+- icon_misc = Gtk.IconTheme.load_icon(icon_theme, "edit-paste", 16, 0)
++ icon_add = Gtk.IconTheme.load_icon(icon_theme, "list-add-symbolic", 16, 0)
++ icon_delete = Gtk.IconTheme.load_icon(icon_theme, "edit-delete-symbolic", 16, 0)
++ icon_edit = Gtk.IconTheme.load_icon(icon_theme, "edit-select-all-symbolic", 16, 0)
++ icon_misc = Gtk.IconTheme.load_icon(icon_theme, "edit-paste-symbolic", 16, 0)
+
+ self.action_icons = {"add": icon_add, "delete": icon_delete, "edit": icon_edit,
+ "misc": icon_misc}
+diff --git a/blivetgui/processing_window.py b/blivetgui/processing_window.py
+index c400f90..a020ae8 100644
+--- a/blivetgui/processing_window.py
++++ b/blivetgui/processing_window.py
+@@ -93,9 +93,9 @@ def add_action_view(self):
+ """
+
+ icon_theme = Gtk.IconTheme.get_default() # pylint: disable=no-value-for-parameter
+- icon_add = Gtk.IconTheme.load_icon(icon_theme, "list-add", 16, 0)
+- icon_delete = Gtk.IconTheme.load_icon(icon_theme, "edit-delete", 16, 0)
+- icon_edit = Gtk.IconTheme.load_icon(icon_theme, "edit-select-all", 16, 0)
++ icon_add = Gtk.IconTheme.load_icon(icon_theme, "list-add-symbolic", 16, 0)
++ icon_delete = Gtk.IconTheme.load_icon(icon_theme, "edit-delete-symbolic", 16, 0)
++ icon_edit = Gtk.IconTheme.load_icon(icon_theme, "edit-select-all-symbolic", 16, 0)
+
+ actions_list = Gtk.ListStore(GdkPixbuf.Pixbuf, str, GdkPixbuf.Pixbuf)
+
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.3.0.bb b/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.3.0.bb
index c26ae1fe98..29e7a267d2 100644
--- a/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.3.0.bb
+++ b/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.3.0.bb
@@ -11,7 +11,8 @@ B = "${S}"
SRCREV = "42512ee48494cee71febf04078d9774f0146a085"
SRC_URI = "git://github.com/storaged-project/blivet-gui.git;branch=master;protocol=https \
file://0001-Use-setuptools-instead-of-distutils-in-setup.py.patch \
- "
+ file://0002-Use-symbolic-list-add-and-edit-icons.patch \
+ "
inherit features_check
REQUIRED_DISTRO_FEATURES = "x11 systemd"