aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2019-11-20 21:31:49 -0800
committerKhem Raj <raj.khem@gmail.com>2019-11-21 17:51:37 -0800
commit4c00e5fed9532fe6ee71ce96b0124fc234b44d4e (patch)
treeec74c3e49a545e37a85befe3d7f970304af5516c /meta-python
parentb77cc676916e7cf06e5a80081aac52a7bdc7d3a9 (diff)
downloadmeta-openembedded-contrib-4c00e5fed9532fe6ee71ce96b0124fc234b44d4e.tar.gz
recipes: rename distro_features_check to features_check
Avoid warning due to the class rename in OE-Core. Signed-off-by: Denys Dmytriyenko <denys@ti.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/pamela_0.3.0.bb2
-rw-r--r--meta-python/recipes-devtools/python/python-pam_1.8.2.bb2
-rw-r--r--meta-python/recipes-devtools/python/python-systemd.inc2
-rw-r--r--meta-python/recipes-devtools/python/python3-pyatspi_2.32.1.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-pystemd_0.6.0.bb2
-rw-r--r--meta-python/recipes-extended/python-blivet/python3-blivet_3.1.4.bb2
-rw-r--r--meta-python/recipes-extended/python-blivet/python3-blivetgui_2.1.10.bb2
7 files changed, 7 insertions, 7 deletions
diff --git a/meta-python/recipes-devtools/python/pamela_0.3.0.bb b/meta-python/recipes-devtools/python/pamela_0.3.0.bb
index 8071fcb04f..030c22f8f3 100644
--- a/meta-python/recipes-devtools/python/pamela_0.3.0.bb
+++ b/meta-python/recipes-devtools/python/pamela_0.3.0.bb
@@ -11,5 +11,5 @@ inherit pypi setuptools
RDEPENDS_${PN} = "libpam"
-inherit distro_features_check
+inherit features_check
REQUIRED_DISTRO_FEATURES = "pam"
diff --git a/meta-python/recipes-devtools/python/python-pam_1.8.2.bb b/meta-python/recipes-devtools/python/python-pam_1.8.2.bb
index 60a3b43de5..bac3496186 100644
--- a/meta-python/recipes-devtools/python/python-pam_1.8.2.bb
+++ b/meta-python/recipes-devtools/python/python-pam_1.8.2.bb
@@ -11,5 +11,5 @@ inherit pypi setuptools
RDEPENDS_${PN} = "libpam"
-inherit distro_features_check
+inherit features_check
REQUIRED_DISTRO_FEATURES = "pam"
diff --git a/meta-python/recipes-devtools/python/python-systemd.inc b/meta-python/recipes-devtools/python/python-systemd.inc
index f01165cf89..b14f825011 100644
--- a/meta-python/recipes-devtools/python/python-systemd.inc
+++ b/meta-python/recipes-devtools/python/python-systemd.inc
@@ -7,7 +7,7 @@ PYPI_PACKAGE = "systemd-python"
DEPENDS += "systemd (<=234)"
RDEPENDS_${PN} += "systemd ${PYTHON_PN}-syslog ${PYTHON_PN}-logging"
REQUIRED_DISTRO_FEATURES = "systemd"
-inherit pypi distro_features_check
+inherit pypi features_check
SRC_URI[md5sum] = "5071ea5bcb976186e92a3f5e75df221d"
SRC_URI[sha256sum] = "fd0e44bf70eadae45aadc292cb0a7eb5b0b6372cd1b391228047d33895db83e7"
diff --git a/meta-python/recipes-devtools/python/python3-pyatspi_2.32.1.bb b/meta-python/recipes-devtools/python/python3-pyatspi_2.32.1.bb
index c60d40e3a2..4f52ac70d0 100644
--- a/meta-python/recipes-devtools/python/python3-pyatspi_2.32.1.bb
+++ b/meta-python/recipes-devtools/python/python3-pyatspi_2.32.1.bb
@@ -12,7 +12,7 @@ SRCREV = "dc4565208fca00da06b972915a080ad3c63f640d"
S = "${WORKDIR}/git"
# Same restriction as gtk+
-inherit distro_features_check
+inherit features_check
ANY_OF_DISTRO_FEATURES = "${GTK2DISTROFEATURES}"
inherit pkgconfig autotools python3native
diff --git a/meta-python/recipes-devtools/python/python3-pystemd_0.6.0.bb b/meta-python/recipes-devtools/python/python3-pystemd_0.6.0.bb
index 89d718de68..02a5c8f857 100644
--- a/meta-python/recipes-devtools/python/python3-pystemd_0.6.0.bb
+++ b/meta-python/recipes-devtools/python/python3-pystemd_0.6.0.bb
@@ -8,6 +8,6 @@ SRC_URI[sha256sum] = "b1fc072c87e3766711f64caf86fd633dca393e20c8a0a37a5058dd70a2
DEPENDS = "systemd"
REQUIRED_DISTRO_FEATURES = "systemd"
-inherit pypi setuptools3 distro_features_check
+inherit pypi setuptools3 features_check
BBCLASSEXTEND = "native"
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivet_3.1.4.bb b/meta-python/recipes-extended/python-blivet/python3-blivet_3.1.4.bb
index fe9d27ab8f..2b5b253b5d 100644
--- a/meta-python/recipes-extended/python-blivet/python3-blivet_3.1.4.bb
+++ b/meta-python/recipes-extended/python-blivet/python3-blivet_3.1.4.bb
@@ -25,7 +25,7 @@ SRC_URI = "git://github.com/rhinstaller/blivet;branch=3.1-release \
UPSTREAM_CHECK_GITTAGREGEX = "blivet-(?P<pver>\d+(\.\d+)+)$"
-inherit distro_features_check
+inherit features_check
REQUIRED_DISTRO_FEATURES = "systemd"
inherit setuptools3 python3native
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.1.10.bb b/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.1.10.bb
index b7e2493c32..92402bee56 100644
--- a/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.1.10.bb
+++ b/meta-python/recipes-extended/python-blivet/python3-blivetgui_2.1.10.bb
@@ -13,7 +13,7 @@ SRC_URI = "git://github.com/rhinstaller/blivet-gui;branch=master \
file://0001-Fix-return-type-of-BlivetUtils.get_disks-1658893.patch \
"
-inherit distro_features_check
+inherit features_check
REQUIRED_DISTRO_FEATURES = "x11 systemd"
inherit setuptools3 python3native