aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorBartosz Golaszewski <brgl@bgdev.pl>2021-03-25 13:33:53 +0100
committerKhem Raj <raj.khem@gmail.com>2021-03-26 10:32:32 -0700
commitccb08248e4ea02373b857ef1975e8a2273b14a69 (patch)
treeb0d2248a140c32adb2bfb9c0164b5dcd09951115 /meta-python
parentda97e1d0af62d1458913462073440bc7b4bf8176 (diff)
downloadmeta-openembedded-contrib-ccb08248e4ea02373b857ef1975e8a2273b14a69.tar.gz
python3-jmespath: new package
Add a recipe for jmespath: a python module implementing a query language for JSON. Signed-off-by: Bartosz Golaszewski <brgl@bgdev.pl> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb1
-rw-r--r--meta-python/recipes-devtools/python/python3-jmespath_0.10.0.bb12
2 files changed, 13 insertions, 0 deletions
diff --git a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
index e4e67221f7..936053c69f 100644
--- a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
+++ b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
@@ -188,6 +188,7 @@ RDEPENDS_packagegroup-meta-python3 = "\
python3-jdatetime \
python3-jdcal \
python3-jedi \
+ python3-jmespath \
python3-jsmin \
python3-jsonpatch \
python3-jsonpath-rw \
diff --git a/meta-python/recipes-devtools/python/python3-jmespath_0.10.0.bb b/meta-python/recipes-devtools/python/python3-jmespath_0.10.0.bb
new file mode 100644
index 0000000000..46976d19b3
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-jmespath_0.10.0.bb
@@ -0,0 +1,12 @@
+SUMMARY = "JMESPath (pronounced 'james path') allows you to declaratively specify how to extract elements from a JSON document."
+HOMEPAGE = "https://pypi.org/project/jmespath/"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2683790f5fabb41a3f75b70558799eb4"
+
+SRC_URI[md5sum] = "65bdcb5fa5bcf1cc710ffa508e78e408"
+SRC_URI[sha256sum] = "b85d0567b8666149a93172712e68920734333c0ce7e89b78b3e987f71e5ed4f9"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "python3-math python3-json python3-numbers"