aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorChangqing Li <changqing.li@windriver.com>2019-11-29 13:34:46 +0800
committerKhem Raj <raj.khem@gmail.com>2019-11-30 00:13:54 -0800
commitae88e8ce9c1dc2dbd4b40fac05f68d6fb03885b0 (patch)
tree1c66a4c28168ecfb6b76d649da0cb91f3b922294 /meta-python
parent6bc470c15e493765a917908abeae56a12182131a (diff)
downloadmeta-openembedded-contrib-ae88e8ce9c1dc2dbd4b40fac05f68d6fb03885b0.tar.gz
python-sqlparse/python3-sqlparse: move from meta-cloud-services
move these recipes from meta-cloud-services, since python3-django RDEPENDS on this, and extend for native and nativesdk. Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-sqlparse.inc13
-rw-r--r--meta-python/recipes-devtools/python/python-sqlparse_0.3.0.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-sqlparse_0.3.0.bb3
3 files changed, 18 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-sqlparse.inc b/meta-python/recipes-devtools/python/python-sqlparse.inc
new file mode 100644
index 0000000000..f71f8152aa
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-sqlparse.inc
@@ -0,0 +1,13 @@
+DESCRIPTION = "Non-validating SQL parser module"
+HOMEPAGE = "http://pypi.python.org/pypi/sqlparse"
+SECTION = "devel/python"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2b136f573f5386001ea3b7b9016222fc"
+
+SRC_URI[md5sum] = "2ce34181d6b7b234c9f3c0ecd1ffb93e"
+SRC_URI[sha256sum] = "7c3dca29c022744e95b547e867cee89f4fce4373f3549ccd8797d8eb52cdb873"
+
+export BUILD_SYS
+export HOST_SYS
+
+inherit pypi
diff --git a/meta-python/recipes-devtools/python/python-sqlparse_0.3.0.bb b/meta-python/recipes-devtools/python/python-sqlparse_0.3.0.bb
new file mode 100644
index 0000000000..2b7773fd4f
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-sqlparse_0.3.0.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require python-sqlparse.inc
diff --git a/meta-python/recipes-devtools/python/python3-sqlparse_0.3.0.bb b/meta-python/recipes-devtools/python/python3-sqlparse_0.3.0.bb
new file mode 100644
index 0000000000..a646ac6486
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-sqlparse_0.3.0.bb
@@ -0,0 +1,3 @@
+inherit setuptools3
+require python-sqlparse.inc
+BBCLASSEXTEND = "native nativesdk"