aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2022-07-06 11:19:38 +0300
committerKhem Raj <raj.khem@gmail.com>2022-07-06 05:08:49 -0700
commit8e1c900eff54c50c9a5137d804a9c5ce6923c292 (patch)
treee9ee183bd45d8ed044ca04654ba265af29bfcd16 /meta-python
parent8babc2e751426ba221af30291c23f9b7b4f3bded (diff)
downloadmeta-openembedded-contrib-8e1c900eff54c50c9a5137d804a9c5ce6923c292.tar.gz
python3-pika: Upgrade 1.2.1 -> 1.3.0
Upgrade to release 1.3.0: - Convert the metadata into PEP 621 format - Use pyproject.toml only - Memory leak when multiple field is set to true in ack - No exception raised when heartbeat timed out - Wrong return type for basic_get Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-pika_1.3.0.bb (renamed from meta-python/recipes-devtools/python/python3-pika_1.2.1.bb)17
1 files changed, 11 insertions, 6 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pika_1.2.1.bb b/meta-python/recipes-devtools/python/python3-pika_1.3.0.bb
index 38f84cf1ba..7ffec26e55 100644
--- a/meta-python/recipes-devtools/python/python3-pika_1.2.1.bb
+++ b/meta-python/recipes-devtools/python/python3-pika_1.3.0.bb
@@ -1,21 +1,26 @@
SUMMARY = "Pika is a RabbitMQ (AMQP 0-9-1) client library for Python."
DESCRIPTION = " \
Pika is a pure-Python implementation of the AMQP 0-9-1 protocol \
-including RabbitMQ’s extensions. \
+including RabbitMQ's extensions. \
"
SECTION = "devel/python"
HOMEPAGE = "https://pika.readthedocs.io"
LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://LICENSE;md5=678ec81495ba50edf81e84e4f1aa69f3"
-SRC_URI[sha256sum] = "e5fbf3a0a3599f4e114f6e4a7af096f9413a8f24f975c2657ba2fac3c931434f"
+SRC_URI[sha256sum] = "15357ddc47a5c28f0b07d80e93d504cbbf7a1ad5e1cd129ecd27afe76472c529"
-inherit pypi setuptools3
+inherit pypi python_setuptools_build_meta
PYPI_PACKAGE = "pika"
+DEPENDS += " \
+ ${PYTHON_PN}-setuptools-scm-native \
+ ${PYTHON_PN}-toml-native \
+"
+
RDEPENDS:${PN} += " \
- ${PYTHON_PN}-logging \
- ${PYTHON_PN}-tornado \
- ${PYTHON_PN}-twisted \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-tornado \
+ ${PYTHON_PN}-twisted \
"