aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorJacopo Dall'Aglio <jacopo.dallaglio@kynetics.com>2019-11-29 13:10:43 +0000
committerKhem Raj <raj.khem@gmail.com>2019-11-30 00:14:02 -0800
commit459dbf10783a89540d9334e823524ec1dbb21502 (patch)
tree43cbcfefbb39140c57262ae7758ff0bd868ee733 /meta-python
parent448a5be9a3c95a6c944e43768d183d9433d36038 (diff)
downloadmeta-openembedded-contrib-459dbf10783a89540d9334e823524ec1dbb21502.tar.gz
python-netifaces: add recipes
With netifaces it's possible to get the addresses of the machine's network interfaces from Python. Network configuration renderers such as Netplan depends on its Python3 implementation. Signed-off-by: Jacopo Dall'Aglio <jacopo.dallaglio@kynetics.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-netifaces.inc10
-rw-r--r--meta-python/recipes-devtools/python/python-netifaces_0.10.9.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-netifaces_0.10.9.bb2
3 files changed, 14 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-netifaces.inc b/meta-python/recipes-devtools/python/python-netifaces.inc
new file mode 100644
index 0000000000..daccc4fba3
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-netifaces.inc
@@ -0,0 +1,10 @@
+DESCRIPTION = "Portable network interface information for Python"
+SECTION = "devel/python"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=a53cbc7cb75660694e138ba973c148df"
+
+SRC_URI[md5sum] = "de92cc322b4f56047c073f802ad77860"
+SRC_URI[sha256sum] = "2dee9ffdd16292878336a58d04a20f0ffe95555465fee7c9bd23b3490ef2abf3"
+
+inherit pypi
diff --git a/meta-python/recipes-devtools/python/python-netifaces_0.10.9.bb b/meta-python/recipes-devtools/python/python-netifaces_0.10.9.bb
new file mode 100644
index 0000000000..c4aa849713
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-netifaces_0.10.9.bb
@@ -0,0 +1,2 @@
+require python-netifaces.inc
+inherit setuptools
diff --git a/meta-python/recipes-devtools/python/python3-netifaces_0.10.9.bb b/meta-python/recipes-devtools/python/python3-netifaces_0.10.9.bb
new file mode 100644
index 0000000000..69d5c674c0
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-netifaces_0.10.9.bb
@@ -0,0 +1,2 @@
+require python-netifaces.inc
+inherit setuptools3