aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2019-08-08 16:18:42 +0200
committerKhem Raj <raj.khem@gmail.com>2019-08-08 14:54:41 -0700
commit3468447d9695bd3383c9839fae59727c99cc5123 (patch)
treef394fcb51fa1040add32c3a0d7cd6eac95bbbb4d /meta-python
parentd2b991fb5d4cab2f025f43f78f8bcc0cb6305fbd (diff)
downloadmeta-openembedded-contrib-3468447d9695bd3383c9839fae59727c99cc5123.tar.gz
python-matplotlib: remove the python 2.x version of the recipe
This recipe depends on 2.x version of NumPy, which is about to be removed from oe-core (due to the latest release of NumPy no longer supporting Python 2.x). 3.x versions remain available as before. Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb2
-rw-r--r--meta-python/recipes-devtools/python/python-matplotlib_2.0.2.bb18
2 files changed, 1 insertions, 19 deletions
diff --git a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
index 82cda5862d..34be9d7629 100644
--- a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
+++ b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
@@ -57,7 +57,7 @@ RDEPENDS_packagegroup-meta-python = "\
python-markupsafe python-pytest-runner python-grpcio python-mccabe python-pytz python-selectors34 \
python-cython python-chardet python-editor python-flask-bootstrap python-html5lib \
python-singledispatch python-redis python-flask-mail python-funcsigs python-snimpy python-pyasn1 \
- python-decorator python-urllib3 python-feedformatter python-matplotlib python-iso8601 \
+ python-decorator python-urllib3 python-feedformatter python-iso8601 \
python-numeric python-robotframework python-django python-simplejson python-wcwidth \
python-configparser python-epydoc python-intervals python-speaklater \
python-aws-iot-device-sdk-python python-constantly python-bitarray python-flask-wtf \
diff --git a/meta-python/recipes-devtools/python/python-matplotlib_2.0.2.bb b/meta-python/recipes-devtools/python/python-matplotlib_2.0.2.bb
deleted file mode 100644
index e586ee4dac..0000000000
--- a/meta-python/recipes-devtools/python/python-matplotlib_2.0.2.bb
+++ /dev/null
@@ -1,18 +0,0 @@
-DESCRIPTION = "matplotlib is a python 2D plotting library which produces publication quality figures in a variety of hardcopy formats"
-SECTION = "devel/python"
-LICENSE = "PSF"
-LIC_FILES_CHKSUM = "file://LICENSE/LICENSE;md5=afec61498aa5f0c45936687da9a53d74"
-
-DEPENDS += "python-numpy freetype libpng python-dateutil python-pytz"
-RDEPENDS_${PN} = "python-core python-distutils python-numpy freetype libpng python-dateutil python-pytz"
-
-SRCREV = "e175a41cb81880dbc553d9140e6ae5717457afa8"
-SRC_URI = "git://github.com/matplotlib/matplotlib \
- file://fix_setupext.patch \
-"
-S = "${WORKDIR}/git"
-
-EXTRA_OECONF = "--disable-docs"
-
-inherit setuptools pkgconfig
-