aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorBinghua Guan <freebendy@gmail.com>2018-07-25 21:49:54 +0800
committerKhem Raj <raj.khem@gmail.com>2018-07-27 07:19:14 -0700
commit95930af10773018676fc1f98d2bb5328dcf0250b (patch)
tree864dc906775dd9e11f37d4436c0185866f73a38c /meta-python
parent0049076c41d547a90bfdfe826038d6ce6c23bd36 (diff)
downloadmeta-openembedded-contrib-95930af10773018676fc1f98d2bb5328dcf0250b.tar.gz
meta-python: add python-inflection recipe
Signed-off-by: Binghua Guan <freebendy@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-inflection.inc14
-rw-r--r--meta-python/recipes-devtools/python/python-inflection_0.3.1.bb4
-rw-r--r--meta-python/recipes-devtools/python/python3-inflection_0.3.1.bb2
3 files changed, 20 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-inflection.inc b/meta-python/recipes-devtools/python/python-inflection.inc
new file mode 100644
index 0000000000..556b26820f
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-inflection.inc
@@ -0,0 +1,14 @@
+SUMMARY = "A port of Ruby on Rails' inflection to Python."
+HOMEPAGE = "https://pypi.org/project/inflection"
+LICENSE = "MIT"
+SECTION = "devel/python"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=de7833d9c2ce0052a4073928c76a13d7"
+
+SRC_URI[md5sum] = "7941165e9f148e0520023941c0886b40"
+SRC_URI[sha256sum] = "18ea7fb7a7d152853386523def08736aa8c32636b047ade55f7578c4edeb16ca"
+
+inherit pypi
+
+RDEPENDS_${PN} += "${PYTHON_PN}-pytest"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python-inflection_0.3.1.bb b/meta-python/recipes-devtools/python/python-inflection_0.3.1.bb
new file mode 100644
index 0000000000..4a9d497912
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-inflection_0.3.1.bb
@@ -0,0 +1,4 @@
+inherit setuptools
+require python-inflection.inc
+
+RDEPENDS_${PN} += "${PYTHON_PN}-codecs"
diff --git a/meta-python/recipes-devtools/python/python3-inflection_0.3.1.bb b/meta-python/recipes-devtools/python/python3-inflection_0.3.1.bb
new file mode 100644
index 0000000000..cc36a02a77
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-inflection_0.3.1.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-inflection.inc