aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDima Zavin <dmitriyz@waymo.com>2018-08-04 17:33:34 -0700
committerKhem Raj <raj.khem@gmail.com>2018-08-05 23:31:10 -0700
commit88c8866fbc5d809987b67eda290c545e4d46c660 (patch)
treeaa78e738558e5a4af7aebf7aeee899b7187b2128 /meta-python
parent83c609bb84358ca7b2232c59f9362594c2a9f2a3 (diff)
downloadmeta-openembedded-contrib-88c8866fbc5d809987b67eda290c545e4d46c660.tar.gz
python3-chardet: add a '3' suffix to binary to avoid conflicts with python2
Signed-off-by: Dima Zavin <dmitriyz@waymo.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-chardet_3.0.4.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-chardet_3.0.4.bb b/meta-python/recipes-devtools/python/python3-chardet_3.0.4.bb
index 038043c568..38d8122ce9 100644
--- a/meta-python/recipes-devtools/python/python3-chardet_3.0.4.bb
+++ b/meta-python/recipes-devtools/python/python3-chardet_3.0.4.bb
@@ -1,2 +1,7 @@
inherit setuptools3
require python-chardet.inc
+
+do_install_append () {
+ # rename scripts that would conflict with the Python 2 build of chardet
+ mv ${D}${bindir}/chardetect ${D}${bindir}/chardetect3
+}