aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2017-08-25 16:40:41 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2017-08-28 11:06:06 +0200
commiteb5163cfbefad3a6131b63f117a9fd389047def1 (patch)
tree77cdc35a4d7b13772ab4bfccbacddbec1348ddd6 /meta-python
parentc7a28011177cb14a695ed2fd2d4b6ed2b6b404da (diff)
downloadmeta-openembedded-contrib-eb5163cfbefad3a6131b63f117a9fd389047def1.tar.gz
python-webencodings: add Python3 support
Extend the recipe for Python3 support. Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-webencodings.inc10
-rw-r--r--meta-python/recipes-devtools/python/python-webencodings_0.5.1.bb12
-rw-r--r--meta-python/recipes-devtools/python/python3-webencodings_0.5.1.bb2
3 files changed, 14 insertions, 10 deletions
diff --git a/meta-python/recipes-devtools/python/python-webencodings.inc b/meta-python/recipes-devtools/python/python-webencodings.inc
new file mode 100644
index 0000000000..ed57c52e56
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-webencodings.inc
@@ -0,0 +1,10 @@
+SUMMARY = "Character encoding aliases for legacy web content"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://PKG-INFO;startline=8;endline=9;md5=af5c81bfe98855a56d36b6ba5de2906f"
+
+SRC_URI[md5sum] = "32f6e261d52e57bf7e1c4d41546d15b8"
+SRC_URI[sha256sum] = "b36a1c245f2d304965eb4e0a82848379241dc04b865afcc4aab16748587e1923"
+
+inherit pypi
+
+RDEPENDS_${PN} += "${PYTHON_PN}-codecs"
diff --git a/meta-python/recipes-devtools/python/python-webencodings_0.5.1.bb b/meta-python/recipes-devtools/python/python-webencodings_0.5.1.bb
index d7e4d2ebba..5de2ed1d7b 100644
--- a/meta-python/recipes-devtools/python/python-webencodings_0.5.1.bb
+++ b/meta-python/recipes-devtools/python/python-webencodings_0.5.1.bb
@@ -1,10 +1,2 @@
-SUMMARY = "Character encoding aliases for legacy web content"
-LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://PKG-INFO;startline=8;endline=9;md5=af5c81bfe98855a56d36b6ba5de2906f"
-
-SRC_URI[md5sum] = "32f6e261d52e57bf7e1c4d41546d15b8"
-SRC_URI[sha256sum] = "b36a1c245f2d304965eb4e0a82848379241dc04b865afcc4aab16748587e1923"
-
-inherit pypi setuptools
-
-RDEPENDS_${PN} += "${PYTHON_PN}-codecs"
+inherit setuptools
+require python-webencodings.inc
diff --git a/meta-python/recipes-devtools/python/python3-webencodings_0.5.1.bb b/meta-python/recipes-devtools/python/python3-webencodings_0.5.1.bb
new file mode 100644
index 0000000000..71fe741e4c
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-webencodings_0.5.1.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-webencodings.inc