aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-09-07 09:56:11 -0700
committerKhem Raj <raj.khem@gmail.com>2019-09-07 10:40:01 -0700
commitfb34a7c583b40c7dd44db01be92b6630caf4cd0f (patch)
treed3831aae2b47568bb882d8a6aaf9eef901392d74 /meta-python
parentdce0799b1389eff2338d07f0ba9285f8b0e92118 (diff)
downloadmeta-openembedded-contrib-fb34a7c583b40c7dd44db01be92b6630caf4cd0f.tar.gz
python-jinja2: Make asyncio specific to python3 module alone
asyncio is not packages seprately with python2 but only with python3 Fixes ERROR: Nothing RPROVIDES 'python-asyncio' (but /mnt/b/yoe/sources/meta-openembedded/meta-python/recipes-devtools/python/python-jinja2_2.10.1.bb RDEPENDS on or otherwise requires it) NOTE: Runtime target 'python-asyncio' is unbuildable, removing... Missing or unbuildable dependency chain was: ['python-asyncio'] Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-jinja2.inc2
-rw-r--r--meta-python/recipes-devtools/python/python3-jinja2_2.10.1.bb2
2 files changed, 3 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python-jinja2.inc b/meta-python/recipes-devtools/python/python-jinja2.inc
index dd9fff86bb..aee7bd3ff4 100644
--- a/meta-python/recipes-devtools/python/python-jinja2.inc
+++ b/meta-python/recipes-devtools/python/python-jinja2.inc
@@ -8,7 +8,7 @@ SRC_URI[md5sum] = "0ae535be40fd215a8114a090c8b68e5a"
SRC_URI[sha256sum] = "065c4f02ebe7f7cf559e49ee5a95fb800a9e4528727aec6f24402a5374c65013"
RDEPENDS_${PN} += "${PYTHON_PN}-io ${PYTHON_PN}-pickle ${PYTHON_PN}-crypt \
- ${PYTHON_PN}-math ${PYTHON_PN}-netclient ${PYTHON_PN}-asyncio \
+ ${PYTHON_PN}-math ${PYTHON_PN}-netclient \
${PYTHON_PN}-pprint ${PYTHON_PN}-shell ${PYTHON_PN}-markupsafe \
${PYTHON_PN}-json ${PYTHON_PN}-threading ${PYTHON_PN}-numbers"
diff --git a/meta-python/recipes-devtools/python/python3-jinja2_2.10.1.bb b/meta-python/recipes-devtools/python/python3-jinja2_2.10.1.bb
index 61156b630b..284f5f588c 100644
--- a/meta-python/recipes-devtools/python/python3-jinja2_2.10.1.bb
+++ b/meta-python/recipes-devtools/python/python3-jinja2_2.10.1.bb
@@ -1,2 +1,4 @@
inherit pypi setuptools3
require python-jinja2.inc
+
+RDEPENDS_${PN} += "${PYTHON_PN}-asyncio"