aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorAaron Chan <aaron.chun.yew.chan@intel.com>2019-07-20 06:07:43 +0000
committerKhem Raj <raj.khem@gmail.com>2019-08-27 12:11:16 -0700
commit2ebaa8df1257389161d0bee9e553c28f63e52005 (patch)
treecdd5ec34b5e4cd51af98aa0893691b787fb71f89 /meta-python
parentecfe351e4674f635def5930ddd74bace562937fc (diff)
downloadmeta-openembedded-contrib-2ebaa8df1257389161d0bee9e553c28f63e52005.tar.gz
python3-pyatspi: Add Dbus ATSPI recipe
pyatspi provide python3 support for Assistive Technology Service Provide Interface (AT-SPI2) protocol over Dbus. This is useful not only for Accessibility (a11y) but also provides a medium for automation of GUI testing (such as python3-dogtail). Signed-off-by: Aaron Chan <aaron.chun.yew.chan@intel.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-pyatspi_2.32.1.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyatspi_2.32.1.bb b/meta-python/recipes-devtools/python/python3-pyatspi_2.32.1.bb
new file mode 100644
index 0000000000..6d80c10915
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pyatspi_2.32.1.bb
@@ -0,0 +1,16 @@
+SUMMARY = "Python bindings for DBus AT-SPI2 accessibility"
+DESCRIPTION = "AT-SPI2 is a protocol over DBus, toolkit widgets use to provide content to screen readers such as Orca"
+SECTION = "devel/python"
+HOMEPAGE = "https://www.freedesktop.org/wiki/Accessibility/AT-SPI2/"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=e9f288ba982d60518f375b5898283886 \
+ file://COPYING.GPL;md5=751419260aa954499f7abaabaa882bbe"
+DEPENDS = "python3-dbus-native glib-2.0 dbus-glib libxml2 atk gtk+ python3-pygobject"
+
+SRC_URI = "git://github.com/GNOME/pyatspi2.git;protocol=https;branch=gnome-3-32"
+SRCREV = "dc4565208fca00da06b972915a080ad3c63f640d"
+S = "${WORKDIR}/git"
+
+inherit pkgconfig autotools python3native
+
+FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}/pyatspi/*"