aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2019-08-21 22:28:53 +0000
committerKhem Raj <raj.khem@gmail.com>2019-08-24 04:31:45 -0700
commit26656c1cd1767c7d6de1d6380ebb92498cf8e912 (patch)
tree3cf383a787d8d0ef3f378a3eee5ecff478898093 /meta-python
parent6b41e0ad6ff76313b2db3cbbf889e50504ce4bb5 (diff)
downloadmeta-openembedded-contrib-26656c1cd1767c7d6de1d6380ebb92498cf8e912.tar.gz
python-socketio: prevent python2 socketio depending on python3-aiohttp
* enable client and asyncio_client PACKAGECONFIGs only in python3-socketio, because there is no python-websockets, python--websocket-client recipes for python2 version * fixes: ERROR: Nothing RPROVIDES 'python3-aiohttp' (but meta-oe/meta-python/recipes-devtools/python/python-socketio_4.3.1.bb RDEPENDS on or otherwise requires it) when python3-aiohttp is blacklisted Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-socketio.inc6
-rw-r--r--meta-python/recipes-devtools/python/python3-socketio_4.3.1.bb2
2 files changed, 5 insertions, 3 deletions
diff --git a/meta-python/recipes-devtools/python/python-socketio.inc b/meta-python/recipes-devtools/python/python-socketio.inc
index 7ebc4eac7a..7ee99f8d99 100644
--- a/meta-python/recipes-devtools/python/python-socketio.inc
+++ b/meta-python/recipes-devtools/python/python-socketio.inc
@@ -12,9 +12,9 @@ PYPI_PACKAGE = "python-socketio"
SRC_URI[md5sum] = "86cd47dddea1785ce7a6c72f55c93fe7"
SRC_URI[sha256sum] = "506b2cf7a520b40ea0b3f25e1272eff8de134dce6f471c1f6bc0de8c90fe8c57"
-PACKAGECONFIG ?= "asyncio_client client"
-PACKAGECONFIG[asyncio_client] = ",,,python3-aiohttp python3-websockets"
-PACKAGECONFIG[client] = ",,,python3-requests python3-websocket-client"
+PACKAGECONFIG ?= ""
+PACKAGECONFIG[asyncio_client] = ",,,${PYTHON_PN}-aiohttp ${PYTHON_PN}-websockets"
+PACKAGECONFIG[client] = ",,,${PYTHON_PN}-requests ${PYTHON_PN}-websocket-client"
RDEPENDS_${PN} += "\
${PYTHON_PN}-engineio \
diff --git a/meta-python/recipes-devtools/python/python3-socketio_4.3.1.bb b/meta-python/recipes-devtools/python/python3-socketio_4.3.1.bb
index ce83d09c0e..8ff590bd75 100644
--- a/meta-python/recipes-devtools/python/python3-socketio_4.3.1.bb
+++ b/meta-python/recipes-devtools/python/python3-socketio_4.3.1.bb
@@ -1,2 +1,4 @@
inherit setuptools3
+
+PACKAGECONFIG ?= "asyncio_client client"
require python-socketio.inc