aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-05-27 00:32:47 +0300
committerKhem Raj <raj.khem@gmail.com>2021-05-28 06:50:20 -0700
commit74eae432d127963f8e910b65a74afd6b787c376d (patch)
tree347a429bc727f2f47e71ca7023ffb6d22f409e82 /meta-python
parent380c0f5f0924d658bf61dbf67817fa64733d6f77 (diff)
downloadmeta-openembedded-contrib-74eae432d127963f8e910b65a74afd6b787c376d.tar.gz
python3-bidict: Add recipe
Add bidict, the bidirectional mapping library for Python. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-bidict_0.21.2.bb11
1 files changed, 11 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-bidict_0.21.2.bb b/meta-python/recipes-devtools/python/python3-bidict_0.21.2.bb
new file mode 100644
index 0000000000..237bd2a63e
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-bidict_0.21.2.bb
@@ -0,0 +1,11 @@
+SUMMARY = "The bidirectional mapping library for Python."
+DESCRIPTION = "The bidirectional mapping library for Python."
+HOMEPAGE = "https://bidict.readthedocs.io/"
+LICENSE = "MPL-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=9741c346eef56131163e13b9db1241b3"
+
+SRC_URI[sha256sum] = "4fa46f7ff96dc244abfc437383d987404ae861df797e2fd5b190e233c302be09"
+
+inherit pypi setuptools3
+
+DEPENDS += "python3-setuptools-scm-native"