aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2019-09-29 13:42:40 +0800
committerKhem Raj <raj.khem@gmail.com>2019-09-30 16:54:51 -0700
commita63859f6a3349fbafe5091ea77fb391347225509 (patch)
tree3976b87260579228ca3c060f840bf5237d6178e1 /meta-python
parenta927a361cf05798adee7674f7118e15abc2a9210 (diff)
downloadmeta-openembedded-contrib-a63859f6a3349fbafe5091ea77fb391347225509.tar.gz
python-statistics: add new recipe
A port of Python 3.4 statistics module to Python 2.*, initially done through the 3to2 tool. This module provides functions for calculating mathematical statistics of numeric (Real-valued) data. This is required by python-pyperf. Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-statistics_1.0.3.5.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-statistics_1.0.3.5.bb b/meta-python/recipes-devtools/python/python-statistics_1.0.3.5.bb
new file mode 100644
index 0000000000..ee3b822a77
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-statistics_1.0.3.5.bb
@@ -0,0 +1,15 @@
+SUMMARY = "A port of Python 3.4 statistics module to Python 2.x"
+DESCRIPTION = " \
+A port of Python 3.4 statistics module to Python 2.*, initially done \
+through the 3to2 tool. This module provides functions for calculating \
+mathematical statistics of numeric (Real-valued) data. \
+"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://statistics/__init__.py;beginline=6;endline=16;md5=b76960ee777a1529f60db47ada2a8e6e"
+
+SRC_URI[md5sum] = "d6d97f3a1a7b3192cff99e0f2b5956c3"
+SRC_URI[sha256sum] = "2dc379b80b07bf2ddd5488cad06b2b9531da4dd31edb04dc9ec0dc226486c138"
+
+inherit pypi setuptools
+
+PYPI_PACKAGE = "statistics"