aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorMing Liu <peter.x.liu@external.atlascopco.com>2017-03-13 16:48:58 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2017-03-16 23:34:32 +0100
commitebd31fd8d519d3e2d26dd14e72d36300f433cfa0 (patch)
treeba98498c66b8cb45251cf631ba9e7b9aaa3dbfb5 /meta-python
parent4b4a62ec0760873b96b738751bf9492aa2efb922 (diff)
downloadmeta-openembedded-contrib-ebd31fd8d519d3e2d26dd14e72d36300f433cfa0.tar.gz
meta: do not prepend/append to BBCLASSEXTEND
Replace some "+=/=+" with "=" when setting BBCLASSEXTEND, they are redundant and inconsistent with the same setting in other recipes. Signed-off-by: Ming Liu <peter.x.liu@external.atlascopco.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-setuptools-scm_1.15.0.bb2
-rw-r--r--meta-python/recipes-extended/python-pyparted/python-pyparted_3.10.7.bb2
2 files changed, 2 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python-setuptools-scm_1.15.0.bb b/meta-python/recipes-devtools/python/python-setuptools-scm_1.15.0.bb
index afbc83ea99..08008cec06 100644
--- a/meta-python/recipes-devtools/python/python-setuptools-scm_1.15.0.bb
+++ b/meta-python/recipes-devtools/python/python-setuptools-scm_1.15.0.bb
@@ -10,6 +10,6 @@ PYPI_PACKAGE = "setuptools_scm"
RDEPENDS_${PN}_class-target = "python-py python-setuptools python-argparse python-debugger python-json"
RDEPENDS_${PN}_class-native = "python-setuptools-native"
-BBCLASSEXTEND =+ "native"
+BBCLASSEXTEND = "native"
inherit pypi setuptools
diff --git a/meta-python/recipes-extended/python-pyparted/python-pyparted_3.10.7.bb b/meta-python/recipes-extended/python-pyparted/python-pyparted_3.10.7.bb
index 712c4b97ab..8335d08c32 100644
--- a/meta-python/recipes-extended/python-pyparted/python-pyparted_3.10.7.bb
+++ b/meta-python/recipes-extended/python-pyparted/python-pyparted_3.10.7.bb
@@ -24,4 +24,4 @@ inherit distutils
RDEPENDS_${PN} += "python-stringold python-codecs python-math parted (>= 2.3)"
RDEPENDS_${PN}_class-native = ""
-BBCLASSEXTEND += "native"
+BBCLASSEXTEND = "native"