aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2017-03-02 20:29:20 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2017-03-07 13:29:45 +0100
commitd911e0f5f15b21fb50a50cfc7ba4873321d7c957 (patch)
tree83e9ae14bb25ae4071776b8d1957cc7626432598 /meta-python
parente54e5fbcee36ad86e34e9f44fc289bbc053a5c3b (diff)
downloadmeta-openembedded-contrib-d911e0f5f15b21fb50a50cfc7ba4873321d7c957.tar.gz
python-babel: add initial recipe for version 2.3.4
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-babel.inc20
-rw-r--r--meta-python/recipes-devtools/python/python-babel_2.3.4.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-babel_2.3.4.bb5
3 files changed, 27 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-babel.inc b/meta-python/recipes-devtools/python/python-babel.inc
new file mode 100644
index 0000000000..866ce78e31
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-babel.inc
@@ -0,0 +1,20 @@
+DESCRIPTION = "A collection of tools for internationalizing Python applications"
+HOMEPAGE = "http://babel.edgewall.org/"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e6eeaabc92cfc2d03f53e789324d7292"
+
+SRC_URI[md5sum] = "afa20bc55b0e991833030129ad498f35"
+SRC_URI[sha256sum] = "c535c4403802f6eb38173cd4863e419e2274921a01a8aad8a5b497c131c62875"
+
+PYPI_PACKAGE = "Babel"
+
+inherit pypi
+
+CLEANBROKEN = "1"
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-numbers \
+ ${PYTHON_PN}-pickle \
+ ${PYTHON_PN}-pytz \
+ ${PYTHON_PN}-threading \
+"
diff --git a/meta-python/recipes-devtools/python/python-babel_2.3.4.bb b/meta-python/recipes-devtools/python/python-babel_2.3.4.bb
new file mode 100644
index 0000000000..e0eadcda8a
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-babel_2.3.4.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require python-babel.inc
diff --git a/meta-python/recipes-devtools/python/python3-babel_2.3.4.bb b/meta-python/recipes-devtools/python/python3-babel_2.3.4.bb
new file mode 100644
index 0000000000..05084ac2e5
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-babel_2.3.4.bb
@@ -0,0 +1,5 @@
+inherit setuptools3
+require python-babel.inc
+
+# Requires _pydecimal.py which is in misc
+RDEPENDS_${PN} += "${PYTHON_PN}-misc"