aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2017-08-19 13:06:00 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-08-28 11:06:02 +0200
commitc64238c764ba3ad7b242407f41b72552cad1413d (patch)
treee993532f2bf781eee24566f28088b4c421d5fb10 /meta-python
parent26ef409d0899a9ca1d2b71cc7a1d78ff1feeea7e (diff)
downloadmeta-openembedded-contrib-c64238c764ba3ad7b242407f41b72552cad1413d.tar.gz
python*-pexpect: add v4.2.1
The python2 version was dropped from oe-core. Also add support for python3. Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-pexpect.inc25
-rw-r--r--meta-python/recipes-devtools/python/python-pexpect_4.2.1.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-pexpect_4.2.1.bb2
3 files changed, 29 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pexpect.inc b/meta-python/recipes-devtools/python/python-pexpect.inc
new file mode 100644
index 0000000000..47d09796d9
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pexpect.inc
@@ -0,0 +1,25 @@
+SUMMARY = "A Pure Python Expect like Module for Python"
+HOMEPAGE = "http://pexpect.readthedocs.org/"
+SECTION = "devel/python"
+LICENSE = "ISC"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=1c7a725251880af8c6a148181665385b"
+
+SRCNAME = "pexpect"
+
+SRC_URI[md5sum] = "3694410001a99dff83f0b500a1ca1c95"
+SRC_URI[sha256sum] = "3d132465a75b57aa818341c6521392a06cc660feb3988d7f1074f39bd23c9a92"
+
+UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/pexpect"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+RDEPENDS_${PN} = "\
+ ${PYTHON_PN}-core \
+ ${PYTHON_PN}-io \
+ ${PYTHON_PN}-terminal \
+ ${PYTHON_PN}-resource \
+ ${PYTHON_PN}-fcntl \
+ ${PYTHON_PN}-ptyprocess \
+"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python-pexpect_4.2.1.bb b/meta-python/recipes-devtools/python/python-pexpect_4.2.1.bb
new file mode 100644
index 0000000000..1c46b47a21
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pexpect_4.2.1.bb
@@ -0,0 +1,2 @@
+require python-pexpect.inc
+inherit pypi setuptools
diff --git a/meta-python/recipes-devtools/python/python3-pexpect_4.2.1.bb b/meta-python/recipes-devtools/python/python3-pexpect_4.2.1.bb
new file mode 100644
index 0000000000..cf39233a3a
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pexpect_4.2.1.bb
@@ -0,0 +1,2 @@
+require python-pexpect.inc
+inherit pypi setuptools3