aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2017-08-25 16:40:42 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2017-08-28 11:06:07 +0200
commit5cdc74cddfbe56e680c9f8a79768c791cc7794bc (patch)
treebd2219257b52286f78b53d8942af6a80f7a15dc6 /meta-python
parenteb5163cfbefad3a6131b63f117a9fd389047def1 (diff)
downloadmeta-openembedded-contrib-5cdc74cddfbe56e680c9f8a79768c791cc7794bc.tar.gz
python-beautifulsoup4: add new recipe for both python2 and python3
Beautiful Soup sits atop an HTML or XML parser, providing Pythonic idioms for iterating, searching, and modifying the parse tree. Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-beautifulsoup4.inc17
-rw-r--r--meta-python/recipes-devtools/python/python-beautifulsoup4_4.6.0.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-beautifulsoup4_4.6.0.bb2
3 files changed, 21 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-beautifulsoup4.inc b/meta-python/recipes-devtools/python/python-beautifulsoup4.inc
new file mode 100644
index 0000000000..d60d987ca0
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-beautifulsoup4.inc
@@ -0,0 +1,17 @@
+SUMMARY = "Screen-scraping library"
+HOMEPAGE = " https://www.crummy.com/software/BeautifulSoup/bs4"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING.txt;md5=f2d38d8a40bf73fd4b3d16ca2e5882d1"
+
+SRC_URI[md5sum] = "c17714d0f91a23b708a592cb3c697728"
+SRC_URI[sha256sum] = "808b6ac932dccb0a4126558f7dfdcf41710dd44a4ef497a0bb59a77f9f078e89"
+
+inherit pypi
+
+RDEPENDS_${PN}_class-target = "\
+ ${PYTHON_PN}-core \
+ ${PYTHON_PN}-html5lib \
+ ${PYTHON_PN}-lxml \
+"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python-beautifulsoup4_4.6.0.bb b/meta-python/recipes-devtools/python/python-beautifulsoup4_4.6.0.bb
new file mode 100644
index 0000000000..907285ac10
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-beautifulsoup4_4.6.0.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require python-beautifulsoup4.inc
diff --git a/meta-python/recipes-devtools/python/python3-beautifulsoup4_4.6.0.bb b/meta-python/recipes-devtools/python/python3-beautifulsoup4_4.6.0.bb
new file mode 100644
index 0000000000..d98df11e3d
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-beautifulsoup4_4.6.0.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-beautifulsoup4.inc