aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorTom Geelen <t.f.g.geelen@gmail.com>2024-05-24 17:43:44 +0000
committerKhem Raj <raj.khem@gmail.com>2024-05-24 14:31:08 -0700
commitcdcea59695f433654885f2fafac216104d1234bf (patch)
treebf71a7406a3c2ec39c57279acd510488f9d29094 /meta-python
parent81647e10c2eb4196b3747701294ebccdaab14467 (diff)
downloadmeta-openembedded-contrib-cdcea59695f433654885f2fafac216104d1234bf.tar.gz
python3-pytest-socket: new recipe
Pytest Plugin to disable socket calls during tests Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-pytest-socket_0.7.0.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pytest-socket_0.7.0.bb b/meta-python/recipes-devtools/python/python3-pytest-socket_0.7.0.bb
new file mode 100644
index 0000000000..86b03724a0
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pytest-socket_0.7.0.bb
@@ -0,0 +1,14 @@
+SUMMARY = "Pytest Plugin to disable socket calls during tests"
+HOMEPAGE = "https://github.com/miketheman/pytest-socket"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=1752f63a3a8a02fed42e580e9b94a081"
+
+SRC_URI[sha256sum] = "71ab048cbbcb085c15a4423b73b619a8b35d6a307f46f78ea46be51b1b7e11b3"
+
+inherit pypi python_poetry_core
+
+RDEPENDS:${PN} = "python3-pytest"
+
+BBCLASSEXTEND = "native nativesdk"
+
+PYPI_PACKAGE = "pytest_socket"