aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorTom Geelen <t.f.g.geelen@gmail.com>2024-05-24 17:43:42 +0000
committerKhem Raj <raj.khem@gmail.com>2024-05-24 14:31:07 -0700
commit81647e10c2eb4196b3747701294ebccdaab14467 (patch)
tree1671047d5697d6fa4b190ffc5c09751ce936e0fe /meta-python
parent58264260c3a0e9710d0915d06addb422cb8fea6d (diff)
downloadmeta-openembedded-contrib-81647e10c2eb4196b3747701294ebccdaab14467.tar.gz
python3-pytest-freezer: new recipe
Pytest plugin providing a fixture interface for spulec/freezegun Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-pytest-freezer_0.4.8.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pytest-freezer_0.4.8.bb b/meta-python/recipes-devtools/python/python3-pytest-freezer_0.4.8.bb
new file mode 100644
index 0000000000..6ff69a3964
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pytest-freezer_0.4.8.bb
@@ -0,0 +1,15 @@
+SUMMARY = "Pytest plugin providing a fixture interface for spulec/freezegun"
+HOMEPAGE = "https://github.com/pytest-dev/pytest-freezer"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=1661a0f2b9b83ed73b8e05b5683b10d0"
+
+SRC_URI[sha256sum] = "8ee2f724b3ff3540523fa355958a22e6f4c1c819928b78a7a183ae4248ce6ee6"
+
+inherit pypi python_flit_core
+
+RDEPENDS:${PN} = "\
+ python3-freezegun (>=1.0) \
+ python3-pytest (>=3.6) \
+"
+
+PYPI_PACKAGE = "pytest_freezer"