aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorTom Geelen <t.f.g.geelen@gmail.com>2024-05-24 17:43:46 +0000
committerKhem Raj <raj.khem@gmail.com>2024-05-24 14:31:08 -0700
commit1c360127e5b8a36b30ea4bf1af3e552df4f463d7 (patch)
tree8e69ed9e3f71ef92fc9439872aa5318714f87004 /meta-python
parentcdcea59695f433654885f2fafac216104d1234bf (diff)
downloadmeta-openembedded-contrib-1c360127e5b8a36b30ea4bf1af3e552df4f463d7.tar.gz
python3-pytest-unordered: new recipe
pytest plugin to Test equality of unordered sequences Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-pytest-unordered_0.6.0.bb12
1 files changed, 12 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pytest-unordered_0.6.0.bb b/meta-python/recipes-devtools/python/python3-pytest-unordered_0.6.0.bb
new file mode 100644
index 0000000000..bf1420cf93
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pytest-unordered_0.6.0.bb
@@ -0,0 +1,12 @@
+SUMMARY = "Test equality of unordered collections in pytest"
+HOMEPAGE = "https://github.com/utapyngo/pytest-unordered"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=fcd3af2d38a4d4dfd5138c6f163dbe2e"
+
+SRC_URI[sha256sum] = "f61b4f6e06a60a92db50968954efac93e2f584290a49f53ad135e3f32f57e02a"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += "python3-pytest"
+
+BBCLASSEXTEND = "native nativesdk"